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Abstract
Andrews, Patricia L.; Bevins, Collin D.; Seli, Robert C. 2005. BehavePlus fire modeling system, version 3.0: 

User's Guide. Gen. Tech. Rep. RMRS-GTR-106WWW. Ogden, UT: Department of Agriculture, Forest Service, 

Rocky Mountain Research Station. 142p.

This publication has been revised for changes made to version 3 of the BehavePlus software, it was originally 

published as the BehavePlus fire modeling system, version 2.0 User’s Guide in June, 2003

The BehavePlus fire modeling system is a program for personal computers that is a collection of mathematical 

models that describe fire and the fire environment. It is a flexible system that produces tables, graphs, and sim-

ple diagrams. It can be used for a multitude of fire management applications including projecting the behavior of 

an ongoing fire, planning prescribed fire, and training. BehavePlus is the successor to the BEHAVE fire behavior 

prediction and fuel modeling system. Primary modeling capabilities include surface fire spread and intensity, 

crown fire spread and intensity, safety zone size, size of point source fire, fire containment, spotting distance, 

crown scorch height, tree mortality, wind adjustment factors, and probability of ignition. The User's Guide 

describes operation of the program. Other papers describe the models and application of the system. 
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Preface
This User's Guide explains how to use the BehavePlus fire modeling system software. Other papers will 

describe the models incorporated into the system and application of the predictions.

This is an RMRS online publication. It can be downloaded from the Rocky Mountain Research Station publica-

tions web page, http://www.fs.fed.us/rm/main/pubs/electronic.html

You can download this User's Guide and the BehavePlus program and provide comments through the Behave-

Plus web site, http://fire.org

This User's Guide is also an integral part of the BehavePlus system, serving as online help.

This publication has been revised from it’s original June, 2003 release. It will continue to be updated as features 

and modeling capabilities are added to the program.

The BehavePlus system is supported by 

USDA Forest Service

National Fire and Aviation Management Information Systems Team

3833 S. Development Avenue

Boise, ID 83705

(800) 253-5559

fire_help@dms.nwcg.gov

What’s New
Version 3 is an upgrade to version 2 that was released in July, 2004. Several major new features have been added 

in version 3. 

• Crown fire modeling

• Table shading for acceptable fire conditions (replaces RxWINDOW in BEHAVE)

• Calculating wind adjustment factors

• A expanded set of standard fuel models

A complete list of version 3 changes can be found in Appendix A

The use of trade or firm names in this publication is for reader information and does not imply

 endorsement by the U.S. Department of Agriculture of any product or service.

http://www.fs.fed.us/rm/main/pubs/electronic.html
http://fire.org
mailto:fire_help@dms.nwcg.gov
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1. Introduction
The BehavePlus fire modeling system is a PC-based program that is a col-

lection of models that describe fire and the fire environment. It is a flexible 

system that produces tables and graphs and can be used for a multitude of fire management applications. 

BehavePlus is the successor to the BEHAVE fire behavior prediction and fuel modeling system (Andrews 1986, 

Andrews and Chase 1989, Burgan and Rothermel 1984, Andrews and Bradshaw 1990). It is called the Behave-

Plus fire modeling system to reflect its expanded scope (Andrews and Bevins 1999).

This document describes operation of the BehavePlus program. The fire models and their application are 

described elsewhere.

Many of the fire models in BehavePlus are the same as those in the FARSITE fire area simulator (Finney 1998), 

NEXUS fire hazard tool, and the FlamMap fire behavior mapping and analysis system. Each system meets a dif-

ferent need. The same surface fire spread model (Rothermel 1972) was used in each case. These three pro-

grams and supporting documentation are available through www.fire.org. Shown below are example outputs 

from each system.

Sample table, graph, and diagram output from BehavePlus:
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Sample fire perimeter output from FASITE:

Sample landscape fire potential output from FlamMap:
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Version 1.0 of BehavePlus was based primarily on the same fire models that composed the old BEHAVE system. 

Development focus was initially on a new look and feel for the program. This paper describes version 3.0, which 

provides additional models and features. A summary of versions 3.0 changes is given in Appendix A.

The primary modeling capabilities of BehavePlus, version 3.0, include 

• Surface fire spread and intensity

• Safety zone size

• Size of a point source fire

• Fire containment

• Spotting distance

• Crown scorch height

• Tree mortality

• Probability of ignition from fire brands or from lightning

• Transition from surface to crown fire

• Crown fire spread

Other modeling capabilities include

• Tables for fine dead fuel moisture 

• Tables for relative humidity or dew point

• Standard and custom fuel models

• Dynamic palmetto-gallberry fuel

• Three methods for weighting two fuel models: two-dimensional expected spread, harmonic mean, area 

weighted 

• Sunrise, sunset, dawn, and dusk at any location or date

Key features include

• Diagrams for point source fire shape, shape of a contained fire, fire characteristics chart, wind / slope / fire 

directions

• Shading of table output for acceptable fire conditions

• Photographs and a key for the standard 13 fuel models

• Distances in map units

• User control of input options and output variables

• Description of each input and output variable

• User control of units and number decimal places displayed

• Multiple values can be entered for almost any input variable

• User interface language can be changed (currently English and Portuguese)
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The help system is an important part of the BehavePlus system. This User's Guide is available with the program 

for help on operation of the program. In addition, a help browser is available in the dialog boxes providing 

immediate information on specific operations and definition of input and output variables as shown below. 
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2. Operation
This User's Guide addresses only operation of the program. The fire mod-

els, associated variables, and application are described elsewhere.

2.1. Organization

Organization of material on Operation of the BehavePlus program is different from the organization of the pro-

gram itself. It is designed to help you find the answer to a question. Most users are comfortable with looking at 

menus and dialog boxes and associated information in the program without use of a User's Guide.

This is not a step-by-step operation manual, but a reference guide. The tutorials provide step-by-step instruc-

tions.

In describing operation of the program, we use the following font and/or conventions in describing menus, com-

mands, buttons, tabs, and check boxes:

Configure > Module selection > SURFACE > Options… > Fuel & Moisture > fuel models radio 

button.

For example the sequence of menus, commands, check boxes, buttons, and tabs shown above refers to the fol-

lowing actions in BehavePlus:

Each of the above elements would be described in this User’s Guide as

1. Configure menu

2. Module selection command

3. SURFACE check box

4. Options... button

5. Fuel & Moisture tab

6. fuel models radio button



Operation DRAFT BehavePlus v3.0 User’s Guide

8 USDA Forest Service General Technical Report RMRS-GTR-106WWW. 2005

Other elements used in BehavePlus include

7. Spin box - select the value using the  buttons or enter a value from the keyboard,

8. Text box - click inside the box to enter values from the keyboard,

9. Drop-down list - Choose the value from the list displayed with the  button.

In the interest of saving space and improving readability, we include screen captures of only the portion of con-

cern. The Tutorials include more complete screen captures.

2.2. Design

2.2.1. Page Oriented

BehavePlus is meant to be more than just a fire modeling tool. It is meant to be a lesson book with a built-in 

training manual, and a planning tool whose results may be incorporated into management reports. It is meant to 

be a fire behavior assessment aid whose tables and graphs can be shared with others in briefings and in written 

documentation.

Because of these expectations, the BehavePlus user interface is designed around the concept of the standard 8.5 

x 11 printed page.

Given input information BehavePlus can generate documentation, diagrams, tables, and graphs. Fortunately, 

BehavePlus has a variety of methods for saving and displaying your work. Six months later when you need to 

review the work, the What, How, and Why of each Run is considerably less obscure than it would have been 

otherwise.

The page on which you enter input information appears first (page 1) and is called the Worksheet. A complex 

Worksheet may span several pages. Once the Calculate button is pressed, BehavePlus generates additional 

pages containing output tables, graphs, and diagrams. These too are deigned to fit neatly on the printed page. 

Navigation buttons on the Tool Bar let you move to the first page, last page, next page, or previous page. The 

Pages menu lets you jump directly to any diagram, table, or graph. The “Print” dialog box lets you print 

selected pages.
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2.2.2. Highly Configurable

BehavePlus is meant to be the repository of many current and future models related to fire behavior and effects. 

These models may have alternate input sets and can produce many output variables. Individual models may be 

linked together so that outputs from one module automatically become inputs for another module. Input and 

output variables may have user-specified units of measure. Outputs may be in the form of diagrams, tables, and/

or graphs. The language displayed on Worksheets and output pages may be changed.

BehavePlus may be used for fire behavior training, for fire planning, or for real-time fire behavior assessment. It 

may be used to assess just fire behavior, or just fire effects, or the link between them. It may be used to build 

custom fuel models, to determine astronomical events, or as a units conversion utility.

2.2.3. Self Documenting

The brooding step-brother of configurability is complexity. Because BehavePlus is so highly configurable and may 

be used by people in various roles for various purposes, it strives to be self-documenting in an attempt to 

thwart entropy. The input Worksheet automatically documents all Modules in use, all input variables and units 

of measure, all output variables and units of measure, and pertinent notes on the current configuration. The 

Worksheet also allows you to enter a Run description (and possibly additional training or fire incident informa-

tion) and contains a notes field for free-field entry of expository text.

2.2.4. User Manual and Help

BehavePlus tries to provide pertinent information to you when you need it the most. The Guide Button  next 

to each entry field opens a dialog box containing a help browser pane with suggested or valid inputs. The help 

browser pane describes input and output variables and program operation. The browser provides tables, pho-

tographs, and figures to help you select inputs.

In addition, this User’s Guide is available as part of BehavePlus with the Help > Program help command. 

2.2.5. Not Boring

Finally, every attempt has been made to keep BehavePlus from becoming yet another boring program with a 

gray personality. Just in case all the complexity, configurability, widgets, dialogs, models, diagrams, tables, graphs, 

browsers, and quirky behavior aren't enough to hold your attention, here and there we've inserted some paint-

ings we rather enjoy to ease our weary eyes.

If you, however, prefer the gray approach, you can eliminate the pictures for the entire session by clearing the 

Show picture pane check box on the Configure > Appearance > Application tab.
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You can also choose to show the art work or not in the dialog boxes with the Picture check box

2.3. Features

2.3.1. Fire Models

BehavePlus contains models to estimate

• surface fire spread rate, intensity, flame length, scorch height, and direction of maximum spread

• surface fire spread rate, intensity, flame length, and scorch height in any compass direction

• crown fire spread rate, critical thresholds, and fire type

• transition from surface to crown fire

• fire shape, area, and perimeter

• spotting distance from a burning pile, from torching trees, or from a wind-driven surface fire

• success or failure of suppression resources to build line around a fire

• recommended fire safety zone radius, separation distance, and zone size

• fire-induced tree mortality

• probability of fire ignition from firebrands

• probability of fire ignition from lightning strikes

• relative humidity or dew point temperature

• midflame wind speed and wind adjustment factor

• fine dead fuel moisture content

• sun-rise, sun-set, dawn, and dusk at any location or date

• palmetto-gallberry dynamic fuels

• create and save custom moisture scenarios

• weighted fire behavior within a two fuel model complex
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2.3.2.  Operation

BehavePlus has the following operational features:

• BehavePlus is cross-platform and works identically on all versions of Windows and Linux.

• Multiple Worksheets may be open at one time.

• Worksheets may be overlaid, tiled, cascaded, and resized.

• Modules (collections of related fire models) may be individually toggled on/off.

• Modules may have alternate input options available through the Configure > Module selection > 

Options… > Input Options tab.

• Module output variables can be toggled on/off via the Configure > Module selection > Options… > 

Output Variables tab.

• Modules may be linked so the outputs from one module are automatically input into another module.

• All distance outputs may be scaled to map units.

• All input and output units of measure may be modified by the user.

• Custom Worksheet configurations may be saved and re-used.

• Custom sets of units of measure may be saved and re-used.

• The Guide Button next to each Worksheet entry field displays a help browser pane with context-specific 

text and either a list of valid choices (for discrete variables) or fields for generating a range of input values.

• Zero, one, or two input variables may have multiple entry values, producing either a simple result list, a 

single one-way table, or a multi-page two-way table, respectively.

• If one input variable has multiple entry values, a separate graph can be generated for each output variable. 

If two input variables have multiple entry values each output variable graph contains a family of curves.

• The SURFACE, SIZE, and CONTAIN Modules can produce diagrams of their results.

• Help > Program help makes this manual and all associated documentation available in PDF format for 

reading, web browsing, and printing.

• The user interface language may be dynamically changed via Configure > Language. Portuguese (Por-

tugal) was made available in version 2 as an example but was not updated to version 3. (Contact cbev-

ins@montana.com if you'd like to volunteer to add support for another language).

• Completed Runs may be saved and re-used.

2.4. Installation

2.4.1. Download

BehavePlus is available for download from www.fire.org. Simply follow the BehavePlus links to the download 

page and select the Windows installation package.

You should check the downloaded file size against the original to ensure you received the entire package. To be 

absolutely certain the package arrived intact, use the md5sum program from a command line prompt:

� md5sum bp_3_0_0.exe

If the resulting 32-digit hexadecimal number is not identical to the one published on the BehavePlus download 

page, your download copy is corrupt.
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2.4.2. System Requirements

BehavePlus has modest system requirements met by the most inexpensive computers available on the market:

• Windows 95, 98, ME, NT, 2000, or XP

• Minimum 800 x 600 video resolution with 256 (8-bit) colors (recommend 1024 x 768 video resolution 

with 64K (16-bit) colors)

• 16 megabytes of available RAM

• 20 megabytes of disk storage

2.4.3. Windows Installation

BehavePlus for Windows is packaged using the Wise Installation System. Simply type the name of the package 

(e.g., bp_3_0_0.exe) at a command prompt (or click on its name in Windows Explorer) and the installation wiz-

ard will guide you through the process. This mostly consists of pressing the OK button.

2.4.4. File Structure

BehavePlus has a proscribed file system structure; all files must be located in specific subdirectories. The parent 

directory of this file structure and all its subdirectories and files are collectively known as a Workspace. When 

BehavePlus is first installed it has a single Workspace called "DefaultDataFolder" as shown below.

This is the default current Workspace every time BehavePlus is started. 

We recommend that you use Workspaces to aid file management as you apply BehavePlus to several projects. 

See the section 20.1, Workspaces, for more information.

A list of three letter file extensions used by BehavePlus is shown in the following table. These extensions are 

automatically attached to the files you create in BehavePlus.

File extension File Type Folder

.bpf Custom fuel models FuelModelFolder

.bpm Moisture scenarios MoistureScenarioFolder

.bpr Runs RunFolder

.bpu Custom Unit Sets UnitsSetFolder

.bpw Worksheets WorksheetFolder
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2.5. Definitions

A Worksheet is the first page or two containing the input Entry Fields. The content of a Worksheet depends 

upon the specific BehavePlus configuration including module selections, input options, output variables, units of 

measure, and diagram/table/graph options. Thus there are a large number of possible Worksheets. Some Exam-

ple Worksheets are supplied with the BehavePlus distribution and are included in every Workspace. You may 

reconfigure BehavePlus as needed for any purpose, then save its Worksheet for later reuse. Functionally, a 

Worksheet is a BehavePlus configuration that does not have any input values associated with it.

A Run is a Worksheet that has a complete set of valid inputs, but no outputs are saved in a Run. You must cal-

culate a saved Run to obtain outputs. Any given Worksheet may have an infinite number of Runs, each deter-

mined by its input values. Runs may be saved for later use and review. The BehavePlus installation includes 

Example Runs.

A Model is a set of equations that estimate one or more output variables from one or more input variables. 

While BehavePlus contains many models, you will more commonly see references to Modules, which are collec-

tions of models.

A Fuel Model is a set of numbers describing a fuel bed used by the surface fire spread model.

A Module is a collection of one or more Models that can be activated/deactivated by the user during Work-

sheet configuration. Selecting the IGNITE Module, for example, includes both the firebrand ignition model and 

the lightning strike ignition model.

A Continuous Variable is an input or output variable that has a continuous range of values. Continuous variables 

have a minimum and maximum valid value. Examples include fuel moisture content, and wind speed.

A Discrete Variable has a finite set of valid values. Examples include Fuel Model, Spotting Source Location, and 

Tree Species.

A Guide Button is the button with the arrow icon next to each Worksheet entry field. Pressing the Guide But-

ton activates an “Input Guide” dialog box containing a help browser pane and input assistance. For continuous 

variables, the dialog facilitates entry of a large number of inputs by specifying the minimum input value, maxi-

mum input value, and increment value. For discrete variables the “Input Guide” dialog box contains a list of all 

valid inputs from which the user may select zero or more values.

A Workspace is a complete subdirectory tree containing all required BehavePlus files plus any additional Work-

sheet, Run, Fuel Model, Moisture Scenario, Units Set, or capture files saved by the user. A Workspace corre-

sponds to a single BehavePlus project, and each BehavePlus project should have its own Workspace. 

Workspaces are created by the File > Workspaces > New workspace and the Files > Workspaces > 

Clone current workspace commands.

2.6. Menus and Toolbar

All BehavePlus operations are available from the menu bar.
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The more common operations, such as Module Selection or Calculate, may also be invoked from Toolbar but-

tons. Toolbar buttons and their equivalent Menu commands are shown below:

Toolbar

Buttons
Definitions Equivalent menu operation

Open a new Worksheet File > New

Open a saved Run File > Open Run

Print this Run File > Print

Module selection Configure > Module selection

Calculate this Run File > Calculate

Display first page Pages > then select page #

Display last page Pages > then select page #

Display previous page Pages > then select page #

Display next page Pages > then select page #

Access User’s Guide Help > Program help



USDA Forest Service General Technical Report RMRS-GTR-106WWW. 2005 15

3. Worksheets
A Worksheet is a form on which you enter input. Worksheets vary in 

appearance and content in response to the current module configuration: a 

SURFACE module configuration requires different inputs than a SPOT module configuration.

Module selection, input options, and output variable selections determine BehavePlus configuration, which in 

turn defines the Worksheet appearance and content.

BehavePlus starts with the BasicStart.bpw example Worksheet. This gives the option of doing a quick basic fire 

behavior Run without having to load or configure a Worksheet.

3.1. Worksheet layout

A BehavePlus Worksheet is more than just an input form; it is the primary source of documentation about the 

Run. Worksheets include the following sections:

Header - The Worksheet header shows the BehavePlus version number, useful for reporting bugs and deter-

mining if you have the most recent update. The header also includes the date and time of the last calculation and 

the page number, which lets you collate the correct pages after printing and spreading them out for further 

study.

Border - The line surrounding the Worksheet body may be modified with the Configure > Appearance > 

Worksheet tab.

Tabs - Zero, one, or more page tabs with labels along the right-hand margin of the Worksheet may be activated 

with the Configure > Appearance > Page Tabs tab.

Documentation - This section lists all the currently selected modules and contains an entry field for the Run 

description. Additional documentation entry fields for training or fire projection applications are optionally acti-

vated on the Configure > Appearance > Worksheet tab.

Input - This section contains the required input data entry fields identified by a short phrase and their units of 

measure. Each entry text box also has a Guide  button that may be pressed for input assistance. Entry text 

boxes are grouped under headings such as "Fuel/Vegetation, Surface/Understory", "Fuel/Vegetation, Overstory", 

"Fuel Moisture", "Weather", "Terrain", and “Fire”.

Acceptable Fire Conditions - Used to enter ranges of acceptable fire behavior when using the table shading 

option. Table shading is enabled by selecting the Configure > Table shading for acceptable fire condi-

tions check box.

Run Option Notes - This section documents some of the configuration settings that are selected for the Work-

sheet.

Output Variables - This section lists all the selected output variables and their units of measure. This section 

may be toggled on/off in the Configure > Appearance > Worksheet tab.

Notes - This section permits the user to enter free-field expository text. The user has control of the size of this 

section or whether it is displayed using the Configure > Appearance > Worksheet tab.

3.2. Example Worksheets

A number of predefined example Worksheets are included with the BehavePlus installation in the Example-

Worksheets folder. Descriptions of the example Worksheets are described in Appendix D. You may use these 

Worksheets as provided, or use them as starting points for your own configuration. Use the File > New com-

mand to open an example Worksheet and proceed to change your module selection, input options, and/or out-

put variables as needed. Once BehavePlus is configured the way you want, you may name and save it as a new 

Worksheet. During subsequent BehavePlus sessions you may load your custom Worksheet and BehavePlus is 

configured as expected.
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Shown below is the SurfaceBasicFrom.bpw example Worksheet:

3.3. Worksheet Sections

3.3.1. Page Header

The header of each page includes the version number of the BehavePlus program and the page number. Once a 

Run is calculated the date and time of the calculation is added. The date and time and page number can be used 

to correctly collate printed documents.

3.3.2. Documentation

Documentation is the header information on the Worksheet. The calculation modules that have been selected 

are listed. Documentation always includes a Description field.
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Additional documentation lines can be added by selecting the Fire projection docu-

mentation and/or Training documentation check boxes from the Configure > 

Appearance > Worksheet tab.

Selecting the Fire projection documentation check box adds the following input fields to the Worksheet:

Selecting the Training documentation check box adds the following input fields to the Worksheet:

Both options can be selected at the same time.

3.3.3. Input section

The required input variables and their units are displayed next to their text boxes. Fuel moisture variables that 

are not required have the text box shaded. In the example below, only 1-h fuel moisture is required for fuel 

model 1, because the other fuel categories are not included in the fuel model. 

The Guide  button for each input variable provides access to definitions and input assistance. Input variables 

are organized by logical association (rather than by calculation module). A table of all possible input variables by 

category is given in Appendix B.
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3.3.4. Input codes

The definition of discrete variable input codes can be displayed by selecting two 

options on the Configure > Appearance > Worksheet tab. Selecting the 

Show description for all discrete variable codes check box displays the 

codes on the Worksheet beneath the variable. The Show descriptions only 

for entered discrete variable codes check box displays the codes used in 

the Run on a separate output page when selected.

For example, on the SPOT module with the Show descriptions for all discrete variable codes check 

box selected, all tree species and spotting source location codes are shown.
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With the Show descriptions only for entered discrete variable codes check box selected a page is 

generated at the end of outputs listing the codes and descriptions used in the Run.

3.3.5. Acceptable Fire Conditions

This section is displayed on the Worksheet when the Table shading for acceptable fire conditions 

check box in the “Module Selection” dialog box is selected.

Acceptable Fire Conditions are fully explained in Chapter 7, Table Shading.

3.3.6. Run Option Notes

For clarification, Run options are given after the input variables. The user does not have the option of suppress-

ing this information. The module using the option is also listed in brackets.

3.3.7. Output variables

Selected output variables and their units can be displayed at the end of the 

input Worksheet using the Configure > Appearance > Worksheet 

tab. The module calculating the output variable is also listed in brackets.

For example:
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3.3.8. Notes

The Notes section of the Worksheet allows the user to enter a large 

amount of text associated with a Run. The user has the option of changing 

the number of lines provided for notes or even eliminating the notes section 

on the Configure > Appearance > Worksheet tab with the Show 

notes section check box and the Notes Lines spin box.

3.3.9. Borders

The border color and thickness on the Worksheet and output pages can be 

changed on the Configure > Appearance > Application tab using the 

Border Color drop-down list and the Border Width spin box. The bor-

der can be eliminated by entering a Border Width of 0.

3.3.10. Page Tabs

Page tabs can be displayed along the right margin of the page. This is useful, for example, to identify Runs for a 

particular fire or training session that are subsequently bound in a three-ring binder or stored in filing folders. 

Page tabs can be added and defined with the Configure > Appearance > Page Tabs tab.

Tabs per page - The size of the tab depends upon the value selected in this spin box. Only one tab is actually dis-

played per page. If tabs per page is 4, the displayed tab occupies one-fourth the page height. If it is 10, the dis-

played tab occupies one-tenth the page height. As this number increases, the displayed tab size decreases.

Tab position - Determines the position of the displayed tab. Tab position 1 is always at the upper edge of the 

right margin.

Tab text - The text to appear on the tab. The text is centered within the tab and will therefore be truncated at 

both ends if it is too long.

Tab text color - A color is selected from the drop-down list.

Tab font size - Font point size is selected using this spin box.
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The above settings create the tab on the Worksheet below:

3.4. Loading a previously saved Worksheet

A previously saved Worksheet can be loaded using

• the File > New command,

• or the  toolbar button.

To see the Worksheets in the folder click on the  button to the left of the folder.

To select a Worksheet either

• double click on it,

• or select and click the OK button.

A set of Worksheets is supplied with the program in the "ExampleWorksheets" folder. A short description is 

given for each. See Appendix D for further description of the "ExampleWorksheets".
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3.5. The 0Startup Worksheet

The 0Startup.bpw Worksheet is a special case. It is used as the starting place for selecting calculation modules. 

It shows no input or output variables, but it sets defaults for all Run settings as described in Appendix C. The 

0Startup.bpw Worksheet was used to initialize all of the example Worksheets.

A Worksheet can be designed to meet specific needs by starting with the 0Startup.bpw Example Worksheet, 

selecting the desired modules, and changing options as needed. The startup Worksheet is named 0Startup.bpw 

to assure that it is the first selection of the Example Worksheets folder.

3.6. Changing a Worksheet

A Worksheet can be changed at any time by changing the selected modules and associated options. The changes 

are in effect only for the current session unless the revised Worksheet is saved. If a Worksheet that came with 

the program in the ExampleWorksheets folder is changed, the revised version must be saved in another Work-

sheet folder.

3.7. Saving a Worksheet or a Run

A Worksheet can be saved for later use with the File > saveAs > Worksheet command. The values entered 

onto the Worksheet are not saved. 

Save the Run, which is just a Worksheet with the defined input values, with the File > saveAs > Run com-

mand.

See the Section 20.4, Save As, for more specific information.
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4. Modules
Modules define a set of fire models for a Worksheet. Selection can be made 

with the Configure > Module command.

The output variables that can be calculated by each module are given in Table 2 of Appendix B.

Indentation indicates that the modules can be linked, which means that output from one module is used as input 

to the other. For example, if both SURFACE and SAFETY are selected, the modules are linked. Output from 

SURFACE is used as input to SAFETY. If only SAFETY is selected, all required input is entered by the user. A 

table of input variables and associated modules is given in Table 1 of Appendix B.

Selection of modules, options, and output variables determines the required input variables on the Worksheet. 

The Options… button is used to configure a module’s input options or change the output variables calculated.

4.1. Input options

Some modules offer options on alternate ways of specifying input. Others do not. For example, clicking the 

MORTALITY Options… button displays the "Mortality Module Options" dialog box with the Bark thick-

ness is input option:
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The bark thickness option affects the input variables included on the Worksheet. If Bark thickness is spec-

ified on the worksheet is selected, the resulting Worksheet is as follows: 

If Bark thickness is estimated from species and d.b.h. is selected, the Worksheet is as follows:

The SURFACE module has many input options. For readability, they are available on several tabs:

4.2. Output Options

The desired output variables are selected through the Options… button associated with each module.The 

selected output determines the input requirements. For example, input variables for the SPOT Module are dif-

ferent for each spotting source.
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Pause the mouse over the name of an output variable to 

see its description in the browser pane. For example, a 

pause over Spotting Distance from a Wind 

Driven Surface Fire in the SPOT Output Vari-

ables tab results in this browser pane.
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5. Entering input
There are several ways to input to the BehavePlus program. Values can be 

typed directly into the input field, choices can be made from a list of valid 

input values, a range of values can be specified, and for some variables, 

selecting from a list of common choices.

5.1. Shaded text boxes

In some cases, input variables depend on values entered elsewhere on the Worksheet. When an input variable 

is not required, its text box is shaded. If a value is entered for a shaded text box, it is not used.

5.2. Direct entry

Values can be typed directly into the variable text boxes and the Enter or Tab keys moves the cursor to the 

next field. The cursor can also be moved to any text box with a mouse click. More than one value can be 

entered for an input variable. Multiple values are separated by a space or comma delimiter. You do not need to 

always specify equal steps. You can enter several independent values separated by delimiters.

For table output a separate row and/or column will be created for each value from the input variable text box. 

For graphs of continuous input variables the curve is drawn between the smallest and largest value entered. 

Graphs of discrete variables will display a separate bar for each input value. See chapter 6, Table output, for 

more on how multiple values affect outputs.

5.3. Input Guide

The “Input Guide” dialog box is opened by clicking the Guide  button to the left of each input variable text 

box.

5.3.1. Continuous variables

Valid input ranges can be viewed in the “Input Guide” dialog 

box.

Single values are entered in just the From text box and a 

second value can be entered in the Thru text box.

For continuous variables the “Input Guide” dialog box allows 

definition of a range of values by a constant increment. For 

example, midflame wind speed from 0 to 20 mi/h in steps of 

5 enters 0, 5, 10, 15, 20 on the Worksheet as shown below. 

You can also enter a decreasing range with a negative step. This is useful when you have two input variables, 

such as wind and fuel moisture, that have opposite effect on fire behavior
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5.3.2. Discrete variables

When the Guide button is clicked for a discrete variable, the allowed selections are given in the center pane of 

the “Input Guide” dialog box.

Clicking the values selects them; you can select several values. This example shows the fuel model "Input Guide" 

dialog box. The Ok button enters the selected fuel models on the Worksheet.

5.3.3. Choices button

Although any value in the valid range can be entered for a continuous variable, in some cases common values 

can be entered with the Choices button.

When available on the “Input Guide” dialog box, clicking the Choices button displays commonly used values.
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After selecting values in the “Slope Steepness” dialog box, clicking Ok enters them on the Worksheet.

5.4. Linked input variables

When using the CONTAIN module, with the multiple resources input option selected some, input vari-

ables are directly associated with each other (an exception to the general BehavePlus rule). For example, a line 

production rate, arrival time, and duration are assigned to each resource. Linked input variables also allow you 

to enter multiple values for more than two input variables. In the following example, although multiple values 

are assigned to several input variables, those variables are linked together, so only a single calculation is done.
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6. Table output
When more than one value is assigned to one or two input variables, table 

output is produced. Tables are produced by selecting the Display table 

results check box in the "Calculate Results" dialog box that displays after 

selecting a File > Calculate command.

6.1. Single value calculation

When each variable is assigned only one value, a simple list of output is given. No table or graph is possible. For 

example:
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6.2. Table output

When more than one value is assigned to a variable, table output is produced. Each output variable is a specified 

column. For example, these multiple Rate of Spread inputs produce the page 2 table below:

6.3. Two way tables

When more than one value is assigned to two variables, a two way table is produced. A table is produced for 

each selected output variable. Either variable can be specified as the row variable in the "Calculate Results" dia-

log box. 

For example, with the above inputs this dialog box appears when you Calculate 

the Run. 

After selecting the Rate of Spread (maximum) option button and clicking the Ok 

button, the following tables are produced:
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Changing the Table Row Variable to the Elapsed Time option button swaps the 

table columns and rows produces the following tables:
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6.4. Table appearance

Table row shading can be enabled with the Configure > Appearance > Tables tab.

Selecting the Shade alternate table rows check box causes all output tables to 

have alternating rows shaded with a background color. This may improve the readabil-

ity of wide tables. If the check box is cleared, tables are displayed without any row 

background color.

The table row background color is selected from the Shade drop-down list.

This table appearance option is used to improve table readability, don’t confuse it 

with the Table shading for acceptable fire conditions output option. See 

chapter 7, Table shading, for more information.

6.5. Multiple pages

There is essentially no limit on the number of values that can be assigned to an input variable. But the resulting 

table might not fit on a single page. For example, if rate of spread is calculated for values from 2 to 30 in steps 

of 2, and elapsed time is specified as the row variable, the table overlaps onto 3 pages.

The > or < symbols lined to the right and/or left of the table heading indicates that there are additional results 

for those variables in the indicated direction.
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The box diagram at the upper left of the pages shows the relative position of the currently viewed page in the 

multi-page table.

In this example, however, it would make more sense to specify rate of spread as the row variable since it pro-

duces a table that fits on a single page as shown below:
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7. Table Shading
Table shading for acceptable fire conditions is designed to display the condi-

tions that contribute to acceptable fire behavior, such as in developing a 

prescribed fire prescription. It replaces the RXWINDOW program of the old BEHAVE system. RXWINDOW 

attempted to reverse the calculations to determine conditions that corresponded to specified fire conditions. 

As additional fire models have become available, this approach is unfeasible. The approach taken in BehavePlus is 

different from that in RXWINDOW. 

7.1. Activating the Table Shading Option

To implement the table shading option select the Table shading for acceptable fire conditions check 

box in the “Module Selection” dialog box.
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Once the Table shading for acceptable fire conditions check box is selected a new section, Accept-

able Fire Conditions, appears on the Worksheet.

Notice that some of the output variables are listed in the Acceptable Fire Conditions section. Not all the 

output variables are available to be constrained. The output variables that can be used to identify acceptable fire 

conditions are listed in Table 2 of Appendix B.

7.2. Entering Acceptable Fire Conditions

In the Acceptable Fire Conditions section each output variable listed has a check box and two text boxes 

for entering the range of acceptable fire conditions. By default the check boxes are cleared. The ranges specified 

in the text boxes are only considered if the output variable check box is selected.

This allows you to view all the output variables you want while only using a subset to define your acceptable fire 

conditions. Of course if an output variable is of no interest then clear it from the Outputs tab for the appro-

priate module and it appears in neither the Acceptable Fire Conditions or Output Variables section.
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After selecting the output variables to define acceptable fire conditions enter the acceptable ranges in the cor-

responding text boxes.

If you decide to clear a check box in the Acceptable Fire Conditions section there is no need to zero out 

the range text boxes, any ranges are ignored if the check box is cleared.

7.3. Viewing Results

After calculating the Run the table output will look like this.
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The output values are crossed out (shaded) except for those specified as acceptable on the Worksheet. The 

table outputs for all output variables are shaded, but only for the ranges selected on the Worksheet in the 

Acceptable Fire Conditions section. For example,

on the Fireline Intensity table, the shaded values are the ones that are outside of the 3-5 ch/h surface rate of 

spread range.

If Fireline Intensity is also selected to define acceptable fire conditions all output tables will change.

For the above ranges using the same fuel, weather, and topography inputs the table outputs looks like this;
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Now acceptable output must meet both ranges of acceptable conditions which further constrains the fuel mois-

ture and wind conditions that give desired results. Selecting two or more variables in the Acceptable Fire 

Conditions section can give very complex results that should be interpreted carefully.
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8. Graph output
When more than one value is entered for one or two input variables, 

graphs can be produced. Graphs are viewed by selecting the Display 

Graph Results check box in the "Calculate Results" dialog box that dis-

plays after Calculate is requested. The form of the graph depends on whether the variables are continuous or 

discrete. The program automatically takes care of the differences for the user.

8.1. Single variable graph

When a range of values is entered for a single continuous variable, a graph is produced by calculating a fixed 

number of points (which can be changed in the Configure > Appearance > Graph Elements tab) over 

the entered range. Intermediate values entered on the Worksheet are ignored. For example, rate of spread 

entry of 5, 7, 9, 11, 13, 15 produces the same graph as rate of spread entry of 5, 15:



Graph output DRAFT BehavePlus v3.0 User’s Guide

44 USDA Forest Service General Technical Report RMRS-GTR-106WWW. 2005

When a range of values is assigned to a discrete variable, a single calculation is performed for each value and a 

bar graph is produced. For example, the following is a comparison of surface fire spread rates for the standard 

13 fire behavior fuel models:

8.2. Two variable graph

When a range of values is assigned to two variables, a graph is produced. If both variables are continuous, the 

variable used for the X-axis can be selected from the "Calculate Results" dialog box. For example:



BehavePlus v3.0 User’s Guide DRAFT Graph output

USDA Forest Service General Technical Report RMRS-GTR-106WWW. 2005 45

In the "Calculate Results" dialog box clear the Display table results check box and accept the defaults in the 

Display graph results section:

Changing the X-Axis Variable to the Midflame Wind Speed (upslope) in the "Calculate Results" dialog 

box produces a very different graph:
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If a range is assigned to two variables, one continuous and one discrete, the continuous variable is always on the 

X-axis. For example:

With two variables, one continuous and one discrete, you no longer have the 

option of changing the X-Axis Variable in the "Calculate Results" dialog 

box.

A graph is not possible when ranges are selected for two discrete variables.

8.3. Axis scales

Setting axis scales is important for getting the best information from your Runs, and especially for comparing 

graph output from different Runs.

8.3.1. X-axis

The X-axis variable and scale are the same for all graphs produced by a Run. The maximum for the x-axis is set 

to be the maximum value specified for the variable on the Worksheet. 
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X Axis Origin and Y Axis Origin (minimum values) can be set for each as either zero or as the variable's 

minimum value as specified on the input Worksheet. The graph origin is set to (0,0) as the default. 

For example, consider the following Run:

Options to define the origin of the graph are set through the Configure > 

Appearance > Graph Size tab. 

Setting both the X Axis Origin and Y Axis Origin to zero produces the follow-

ing graph:
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In the Configure > Appearance > Graph Size tab select Min Value from the 

X-Axis Origin drop-down list to alter the graph appearance.

8.3.2. Y-axis

The Y-axis scale normally differs between graphs produced by a Run since each graph is for a different output 

variable. For example, fireline intensity and flame length have different ranges of output and require a different 

Y-axis scale. By default the Y-axis is scaled to the maximum calculated output value for the variable to make best 

use of the graph area.

When you want to compare graphs between Runs, different Y-axis scales can obfuscate the comparison. A rate 

of spread graph for fuel model 10, for example, usually has a narrower output range than for fuel model 5 under 

the same conditions. To better compare calculated rate of spread graphs for the two fuel models, you can set 

both graphs to have the same Y-axis scale.
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The following Run is for fuel model 10, which has relatively low rates of spread.

With the X Axis Origin and Y Axis Origin set to zero, the rate of spread graph below is produced:

To compare the results for fuel model 10 with the faster spreading fuel model 5, the scale for the fuel model 10 

Run is changed to match that produced by model 5. The calculated maximums are given for each of the selected 

output variables as a reference.

In the "Calculate Results" dialog box select the Specify graph Y axis limits 

check box if you wish to modify the Y-axis ranges of the output graphs before 

they are displayed.
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This displays the "Graph Limits" dialog box, where you can change the Y-axis maximum for the variable Rate of 

Spread (maximum) to 40:

The comparison with the corresponding graph for fuel model 5 is now more straightforward now that the axis 

are the same.
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8.4. Graph appearance

The appearance of the graph can be changed through the Configure > Appearance > Graph Size and 

Configure > Appearance > Graph Elements tabs.

8.4.1. Graph Size

The vertical graph height on the page is set with the Graph Size(%) spin box on 

the Configure > Appearance > Graph Size tab.

Graphs are drawn starting at the upper left corner of the page and may occupy 25% 

to 100% of the page height. The default is 50%, as shown in the following graph.
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Changing the Graph Size to 100% changes the above to the following graph:
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8.4.2. Graph Title

The graph title content is controlled using the Graph Title drop-down list on the 

Configure > Appearance > Graph Size tab.

Selecting Short from the Graph Title drop-down list displays just the contents of 

the Worksheet Description text box as the title. Selecting Long displays the 

Description text box and the graph variables.
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Using the above Run a graph with a short title (the default) looks like the following.

Selecting Long from the Graph Title drop-down list on the Configure > 

Appearance > Graph Size tab adds more information to the title.
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8.4.3. Graph colors

Graph colors can be changed with the Configure > Appearance > Graph Elements tab.

Colors are selected from the predefined drop-down lists.

Background is the background color of the graph.

Rainbow Colors sets the number of colors used to display graph lines or bars when Rainbow Colors is 

selected as the curve color. With three rainbow colors, the colors are red, green, and blue. If 4 colors are 

requested, four equally spaced hues from the color spectrum are used to display each graph line or bar in turn. 

Bar Color is used to fill graph bars. Selecting Rainbow Colors fills each bar with its own color. The number of 

rainbow colors is set by the Rainbow Colors spin box discussed above. 

Curve Color is used to draw graph lines. Selecting Rainbow Colors draws each line with its own color. The 

number of rainbow colors is set by the Rainbow Colors spin box discussed above. 

Axis Color is used to draw graph axis lines, tic marks, and axis labels. 

Gridline Color is for the graph grid lines. The default is yellow.
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Changing Rainbow Colors to 10 results in the following graph coloring:

8.4.4. Line widths

Line widths can be changed using the Curve Width, Axis Width, and Grid-

line Width spin boxes on the Configure > Appearance > Graph Ele-

ments tab.

Curve Width sets the width of graph lines. 0 is the thinnest and 9 thickest.

Axis Width sets the width of axis lines drawn on the graph. 1 is thinnest and 9 

thickest.

Gridline Width sets the width of grid lines drawn on the graph. 1 is thinnest 

and 9 thickest. To prevent the display of any grid lines set Gridline Width to 

0.
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The following graph uses the default line settings.

8.5. Number of curve points

The resolution of the curves can be changed with the Curve Points spin box 

on the Configure > Appearance > Graph Elements tab.

The Curve Points spin box determines the number of points calculated for 

each curve in the graph. A straight-line segment is drawn between each pair of 

points. The default of 20 is visually adequate for most graphs. Requesting more 

points usually results in a marginal improvement in the visual appearance and 

requires more computation time. In cases where many curves are plotted and 

the calculation time is slow, reducing the number of curve points will speed 

things up.

Changing Curve Points from the default of 20 to 5 results in the following 

graph:
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Compare with the graph in the previous Line widths section. The fewer line points give the curves a more 

jagged appearance.
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9. Diagram output
In addition to the usual table and graph output, BehavePlus produces dia-

grams for the following output variables. 

• Wind/slope/fire spread direction diagrams from the SURFACE module

• Fire characteristics chart from the SURFACE module

• Shape of a point source fire from the SIZE module

• Shape of a fire after suppression action from the CONTAIN module

Diagram output is selected from the lists on the Configure > Module selection > (module name) > 

Options… > Outputs tab for the corresponding module.

9.1. Wind/slope/spread direction

Direction diagrams can help the user avoid confusion on directions for wind, slope, and spread directions. 

Direction input options are selected on the Configure > Module selection > SURFACE > Options… > 

Directions tab.

Direction diagrams are produced with the Configure > Module selection > SURFACE > Options… > 

Outputs tab and selecting the Wind/Slope/Spread Direction Diagram check box.

The diagrams differ according to the direction Input Options selected from the Configure > Module selec-

tion > SURFACE > Options… > Directions tab. The following shows the Input Option selection, the 

resulting Worksheet, the outputs table and diagrams.
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The following illustrates the effect of selecting the Wind & spread directions are radio button on the vari-

ables that are requested on the Worksheet.
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9.2. Fire characteristics chart

A fire characteristics chart diagram plots the relationship of rate of spread, heat per unit area, flame length, and 

fireline intensity. This option is a simplified plot and does not offer the user any display options. Axis scales are 

set automatically and points are labeled with simple numbers. In the future, BehavePlus will provide a Fire Char-

acteristics Tool so that the user can customize it for a specific need.

Fire characteristics charts are produced with the Configure > Module 

selection > SURFACE > Options… > Outputs tab and selecting the Fire 

Characteristics Chart check box.

It is not necessary to select the four output variables that are plotted on the 

chart.
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The following shows the Worksheet and resulting output table and Fire Characteristics Chart.
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The points labeled 1, 2, and 3 correspond to the three lines of the output table. Point 1 is for fuel model 2, 

point 2 for fuel model 5, and point 3 for fuel model 10.

In the case of two variables with multiple entry values a two-way table is produced:
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The numbers on the chart correspond to the table cells in left-to-right and top-to-bottom order. In this exam-

ple, Points 1 and 2 are for the first row of the result table (3% moisture) at the two wind speeds (7 and 10 mi/

h). Points 3 and 4 are for the second row of the result table (6% moisture) at the two wind speeds. Points 5 and 

6 are for the third row of the result table (9% moisture) at the two wind speeds.

9.3. Shape of a point source fire

The elliptical shape of a point source fire can be plotted on the Configure > Module 

selection > SIZE > Options … > Output Variables tab by selecting the Fire 

Shape Diagram check box.

For example, the following shows the Worksheet, output table, and Fire Shape Diagram.
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In addition to the shape diagrams, values for all of the selected output variables are given on each diagram.

A word of caution when using the SIZE module by itself as shown by the above example. The above diagram 

could be wrongly interpreted to show that higher wind speeds result in a smaller fire. But remember the sur-

face rate of spread (10 ch/h) was the same for o and 6 m.p.h. winds, which is not realistic if all other fire envi-

ronment conditions were the same. In this example the wind speed only determines the shape of a fire for a 

given forward spread distance. 
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When the SIZE Module is linked to the SURFACE Module, the wind vector is also shown on the diagram.
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9.4. Containment shape

The Containment Diagram shows fire perimeter at time of report, at initial attack, and constructed fireline at 

the time the fire was successfully contained or when it escaped initial attack (all resources exhausted before 

containment). 

The Containment Diagram is displayed by selecting the Containment Diagram 

check box from the Configure > Module selection > CONTAIN > Options … 

> Output Variables tab. Also select the Contain Status check box to output 

whether the fire was Contained or Escaped on the Containment Diagram.
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10. View, print, & capture results

10.1. View size

The View > xx% command changes the size of your Worksheet 

and Run when viewed on screen. It does not affect the size of 

printed output.

10.2. Pages

While each Run has its own window, the window has one or more Pages. The first page(s) contain the Work-

sheet, and subsequent pages contain results tables, graphs, and diagrams.

You can navigate between pages using the following toolbar buttons:

 Go to the first page

 Go to the last page

 Go to the previous page

 Go to the next page

The keyboard navigation arrows will also move you from one page to the next. The Pages > command allows 

you to jump directly to a specific page.

10.3. Windows

When a Worksheet is first opened, the Run it represents is assigned a 

default name such as "unnamed01.bpr", "unnamed02.bpr", etc. This 

name is displayed on the title bar at the top of the BehavePlus applica-

tion window.
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When you save a Run with the File > saveAs > Run command you should rename the Run. The name of the 

Run is then displayed in the title bar of the BehavePlus window. The complete path name for the Run is shown 

at the bottom of the BehavePlus application window.

BehavePlus allows you to have any number of Runs open at 

once. Each Run has its own display window containing a Work-

sheet and possibly containing calculation results. Only one Run 

window is active at a time. The Windows menu item allows 

you to switch between Runs. It also allows you to cascade or 

tile the Runs within the BehavePlus window area with the 

Windows > Cascade or Windows > TIle commands. By 

default the Run windows are stacked on top of each other, so 

you only see the active Run. If your Run windows are already cascaded or tiled, you can make a Run active by 

clicking it.

The following is a "tiled" display of the two Runs, one English, one metric. The English Run (unnamed01.bpr) is 

the active Run.

Selection can be made from the list of pages with text descriptions and an icon indicating whether it is a table, 

graph, diagram, etc.

10.4. Print

You can print all pages or selected pages with the File > Print command. Alternatively, select Print from the 

shortcut menu when you right click inside a page.

Whenever an output page is printed, it is good practice to print the associated Worksheet pages to avoid con-

fusion on conditions for the Run. Printed pages are numbered and the date and time of the Run are included on 

the page header.
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10.5. Saving Output

You can save your BehavePlus table output several ways. Tables, graphs, and diagrams can all be saved as an 

image of the screen display. The image file can then be edited with an image processor or inserted into word 

processor or layout documents. Table output can also be saved to a tab delimited text file or HTML file. The 

text file can then be imported into another application, such as word processor, spreadsheet, or database. The 

HTML file can be used in a Web page or is a handy, compact way to E-mail your BehavePlus results.

10.5.1. Saving a screen image

The currently displayed page can be captured and saved as a file in bmp, jpg, or png format with the File > 

saveAs > Image command. In the "Save As" dialog box enter a file name in the Capture File text box and 

select a file type from the Capture Type drop-down list. The file extension will be automatically added to the 

file name

In addition to the File > saveAs > Image command, you can use the ALT-Print Screen key or a screen cap-

ture utility (e.g. FullShot) to insert results from BehavePlus in other documents. The following steps are an 

example and do not constitute endorsement of specific software.

• Startup BehavePlus, WORD word processor, and FullShot software.

• On BehavePlus display, select the 'R' (for Region) in upper right hand of the window (put there by 

FullShot).

• Use the cursor to select the desired area

• Upon release of the mouse, FullShot opens with the selected image

• CTRL-C to save it in a clip board

• Go to the WORD document

• CTRL-V to insert the image

This is a quick and efficient method. There is no need to save the image in a file of its own. The image can be 

resized, cropped, or moved within WORD if desired.

10.5.2. Saving a Text File

Once you have calculated a Run you can save the table output as a tab delimited text file. Select the File > 

saveAs > Results > Spreadsheet command to open a standard Windows “Save As” dialog box. You can 

save this file anywhere, it does not have to be in a BehavePlus Workspace. The .123 file extension will be auto-

matically added to your file name.

To use this file in Microsoft Excel, select the File > Open command and select your saved text file from the 

“Open” dialog box. Make sure that All Files (*.*) is selected from the Files of Type: drop down list at the 

bottom of the dialog box. Then follow the instruction in the “Text Import Wizard”, accepting the defaults and a 

simple Run should look something like this in Excel.
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10.5.3. Saving a HTML File

Once you have calculated a Run you can save the Run as a HTML file. In addition to the table outputs the HTML 

file also contains the Input Variables and Run Option Notes sections of the Worksheet. Select the File > 

saveAs > Results > HTML command to open a standard Windows “Save As” dialog box. You can save this 

file anywhere, it does not have to be in a BehavePlus Workspace. The .html file extension will be automatically 

added to your file name.

Simply double-clicking your saved file will display your Run in your Web browser.
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11. Error checking
If you do something that causes the program to crash, it is a program bug. 

Please report it through www.fire.org.

When you do something in error, the program will tell you what the problem is and give you a chance to fix it.

http://fire.org/mason/nav.cgi?pages=behaveplus2&mode=17
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12. Fuel models
A fuel model is a set of values that describe a fuel type for the surface fire 

spread model. The original standard fuel models are numbered 1 through 

13. An expanded set of 40 fuel models is also available. Additionally Custom Fuel Models, can be developed, 

tested, saved, used in BehavePlus, and exported for use in other applications.

12.1. 13 Standard fuel models

The original 13 standard fuel models are always available by using the Fuel Model Input Guide  Button or 

entering the fuel model code directly into the text box from the keyboard. A complete description of the 13 

standard fuel models is found in the publication Aids to Determining Fuel Models For Estimating Fire Behavior. 

Gen. Tech. Rep. INT-122. Anderson, 1982. These fuel models are found at the top of the list in the Fuel Model 

“Input Guide” dialog box.

12.2. Palmetto-Gallberry fuel option

The palmetto-gallberry fuel option estimates fuel parameters from vegetation characteristics. (Hough and Albini 

1978) The Palmetto-Gallbery fuel option is not selected from the “Input Guide” dialog box like fuel models, but 

is selected with the palmetto-gallberry radio button on the Configure > Module selection > SUR-

FACE > Options… > Fuel & Moisture tab.
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The Palmetto-Gallberry option cannot be used with other fuel models in a Run, it can only be used by itself. 

Notice that “P-G” has been added to each of the input variables on the Worksheet used specifically for the pal-

metto-Gallberry fuel model.

12.3. Expanded set of 40 fuel models

The expanded set of 40 fuel models is also always available in BehavePlus. These fuel models are also selected 

from the Fuel Model Input Guide or entered directly in the Fuel Model text box on the Worksheet. They 

are listed after the original 13 in the “Input Guide” dialog box, but they use an alpha-numeric code rather than 

a number for the value on the Worksheet.

Notice that the expanded models are identified as dynamic or static with a (D) or (S) in the description. See 

Section 11.4 below for more on dynamic fuel models. An example Run, FuelCompare.bpr, can be found in the 

ExampleRuns folder to explore the expanded fuel model set and see the effect of dynamic fuel models. A full 

description of the expanded fuel model set is found in Scott and Burgan, 2004.

12.4. Dynamic fuel models

Dynamic load transfer of herbaceous fuel is available in BehavePlus. If the Fuel Model Type is identified as 

dynamic and contains live herbaceous fuel, then fuel load is transferred from live to dead as a function of the 

Live Herbaceous Moisture entered on the Worksheet. Dynamic fuel models must have a live herbaceous 

fuel load while with static fuel models a live herbaceous fuel load is optional.

The original 13 standard fuel models are static. In the expanded set models that contains a live herbaceous fuel 

load are dynamic. The dynamic fuel models are identified by a (D) at the end of their description and a Fuel 

Model Type parameter of D.

Two output variables are available to help users understand dynamic fuel modeling. Live Herb Load Trans-

fer and Dead Herbaceous Fuel Load can be selected on the Configure > Module selection > SUR-

Dynamic Fuel Model 

Combinations

Live Herbaceous Fuel Load

Yes No

Fuel 

Model 

Type

Dynamic Ok n/a

Static Ok Ok
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FACE > Options… > Outputs tab. A full explanation of dynamic fuel modeling is found in Scott and Burgan, 

2004.

12.5. Custom fuel models

In addition to the standard fuel models you can create, save, and reuse custom fuel models in BehavePlus. These 

custom fuel models can be exported in a file format used by FARSITE, NEXUS, and FlamMap.

12.5.1. Defining and saving custom fuel models

The first step in creating a custom fuel model is to change the Worksheet so that individual fuel parameters are 

entered in place of the fuel model code. Use the Configure > Module selection > SURFACE > 

Options… > Fuel and moisture tab and select the fuel parameters. radio button.

Or you can load the Example Worksheet FuelModeling.bpw, which as been set up to use fuel parameters, using 

the File > New command or  toolbar button.
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Fuel model parameters can be typed directly into the parameter text boxes. Or they can be initiated with an 

existing fuel model by clicking the Initialize from a Fuel Model button on the Worksheet.

The process of developing a custom fuel model is more complex that just filling in these blanks. It involves a 

process of evaluation and revision which is not covered in this User’s Guide. 

Once the fuel model parameters are defined, a custom fuel model can be saved for later use with the File > 

saveAs > Fuel model > BehavePlus format command. In the "Save As" dialog box enter a file name in 

the Fuel Model File text box and a short description in the Fuel Model Description text box. If more 

than one value is assigned to a fuel model parameter for testing purposes, the first value in the list is the one 

that is saved.

Fuel models should be grouped in folders named by some logical association of meaning to the user. See Section 

20.4, Save As, for more information.
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12.5.2. Using previously saved custom fuel models

In order to use previously saved custom fuel models, the folder in which they are stored must be attached using 

the Configure > Fuel model set selection command.

Click on a folder's  button to view its fuel model files. Each fuel model is stored in a separate file.

Fuel model files are attached by attaching the folder in which they reside. This makes the fuel models in that 

folder accessible for use. It is not possible to select and attach individual fuel models; the entire folder must be 

attached. For example, all the southern California fuel models are attached by selecting the SoCalifornia 

folder in the “Fuel Model” dialog box and clicking the Ok button. Once a fuel model folder is attached, the fuel 

models appear in the Fuel Model input guide and may be entered as the Fuel Model input variable.

After the SoCalifornia fuel model folder is 

attached, the Fuel Model input Guide  But-

ton gives the following valid selections for the 

Fuel Model text box.

To view the parameters of a particular fuel 

model, right-click on it’s name and select the 

View parameters command from the short-

cut menu.



Fuel models DRAFT BehavePlus v3.0 User’s Guide

82 USDA Forest Service General Technical Report RMRS-GTR-106WWW. 2005

When viewed in the “Fuel Model” dialog box (opened with the Configure > Fuel model set selection 

command), folders and files with a paper clip icon are currently attached to (i.e., accessible for use by) Behave-

Plus in the current session. Once the Ok button is pressed, only the currently selected folders will have their 

files attached. Unselected folders will NOT have their files attached, even if they are currently marked as 

attached by the paper clip icons. 
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Custom fuel models are selected just like the standard models. They can be selected with the Fuel Model input 

guide or entering the fuel model code directly into the text box from the keyboard.

12.5.3. Exporting custom fuel models

Custom fuel models you create and save in BehavePlus can be exported in the Custom Fuel Model (.fmd) file 

format used by FARSITE, NEXUS, and FlamMap. To avoid confusion, remember the distinction between saving 

and exporting custom fuel models; saving a fuel model lets you reuse it only in another BehavePlus session, 

while exported fuel models can only be used in an application that uses the Custom Fuel Model (.fmd) file for-

mat. Files with a .fmd extension cannot be used in BehavePlus and .bpf files cannot be used in FARSITE, NEXUS, 

or FlamMap.

Before you can export a BehavePlus custom fuel model it must be saved and attached. See Sections 11.5.2 and 

11.5.1 above for information on saving and attaching custom fuel models.
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To export a custom fuel model use the File > saveAs > Fuel model > FARSITE format command. In the 

“Fuel Model Export Selection” dialog box the attached custom fuel models are found at the end of the standard 

fuel models list.

For custom fuel models both the Sort and Code columns in the list display the file name truncated to five 

characters. You select one or more fuel models to export and then click the Ok button. Type the filename in 

the “Save As” dialog box and BehavePlus will automatically attach a .fmd extension.

The exported .fmd file will look similar to this when viewed in a text editor.

The first field for each fuel model is the fuel model number. Exported fuel models begin with number 14 and 

continue to 90 if you elect to export that many fuel models. If these fuel model numbers do not match the land-

scape file in FARSITE or FlamMap you should change these to match by editing the exported .fmd file. You may 

also want to edit the second field, the fuel model code. The default that is exported is the first five characters of 

the BehavePlus .bpf filename.
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13. Moisture scenarios
A moisture scenario is a set of fuel moistures for 1-h, 10-h, and 100-h dead 

fuel and herbaceous and woody live fuel. It is analogous to the fuel model 

concept in that a single code represents a set of live and dead fuel moisture values. Fuel moisture scenarios may 

be developed, for example, to represent local 90-, 95-, and 97-percentile weather situations. The set of mois-

ture scenarios used in the old BEHAVE TSTMDL fuel modeling program and the set used to test the expanded 

standard fuel models are provided with the BehavePlus program.

Fuel model scenarios are for developing and comparing fuel models. They are not designed for fire behavior 

prediction, in which case actual fuel moisture values should be assigned directly.

13.1. Using previously saved moisture scenarios

In order to use previously saved moisture scenarios, the folder in which they are stored must be attached. A 

folder of moisture scenarios is attached using the Configure > moisture Scenario set selection com-

mand to open the "Moisture Scenarios" dialog box.

Click on a folder's  to view its moisture scenario files. Each moisture scenario is stored in a separate file. The 

details of a moisture scenario can be viewed or printed by right-clicking and selecting the appropriate command 

from the shortcut menu.

Moisture scenario files are attached by selecting the folder in which they reside and clicking the Ok button in 

the “Moisture Scenario” dialog box. This makes all the moisture scenarios in that folder accessible for use. It is 

not possible to select and attach individual moisture scenarios; the entire folder must be attached. For example, 

one set of the moisture scenarios that come with the BehavePlus program are attached by selecting the 

FuelModeling folder. Once a moisture scenario folder is attached, its moisture scenarios appear in the Mois-

ture Scenario input guide.

Worksheet options also need to be set to use moisture scenarios. Set up the Worksheet to enter fuel mois-

tures with moisture scenarios using the Configure > Module selection > SURFACE > Options… > 

Fuel & Moisture tab and select the Moisture is entered by moisture scenario. radio button.
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After the FuelModeling moisture scenario folder is attached, the Moisture Scenario Guide  button on 

the Worksheet shows the following valid selections for moisture scenarios in the “Input Guide” dialog box.

To view the parameters of a particular moisture scenario, right-click on the description and select View 

parameters from the shortcut men.

When viewing folders (and files) in the "Moisture Scenario" dialog box, those scenarios with a paper clip icon 

are currently attached to (e.g., accessible for use by) the BehavePlus application. Once the Ok button is 

pressed, only the selected folders will have their files attached. Currently attached folders will NOT have their 

files attached if not selected when the Ok button is clicked. Use the Cancel button to maintain the current 

attached sets. 
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This Worksheet creates the following graph. The fuel model used is a dynamic type, and the output graph indi-

cates the dramatic effect the live fuel moisture can have when using a dynamic fuel model.

13.2. Defining and saving moisture scenarios

To define a Moisture Scenario first set the Worksheet to require individual fuel moisture values by selecting 

individual size class in the Configure > Module selection > SURFACE > Options… > Fuel & 

Moisture tab.
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Enter values for each size class on the Worksheet, even if that item is shaded. Other input text boxes don't 

matter.

Save the moisture scenario with the File > saveAs > Moisture scenario command. In the "Save As" dialog 

box enter a file name in the Moisture Scenario File text box and a short description in the Moisture 

Scenario Description text box. See Section 20.4, Save As, for more information on saving moisture scenar-

ios.
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14. Map applications
BehavePlus allows the calculation of slope steepness from map measure-

ments and conversion of distances to map measurements.

Map scale is given as map representative fraction, which is the ratio of the number of units on the map between 

two points to the distance on the ground between the same two points. For example, if the map representative 

fraction is 1:24,000, then for each inch on the map there are 24,000 inches on the ground.

Although any value can be entered, the "Input Guide" dialog box provides common map scales, available by 

clicking the Choices button.

14.1. Slope from map measurements

To set up a Worksheet to calculate slope steepness from measurements on a topographic map use the Config-

ure > Module selection > SURFACE > Options… > Slope tab and select the Slope steepness is 

calculated from map measurements radio button.
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You can add the calculated slope steepness and intermediate values to the output list with the Configure > 

Module selection > SURFACE > Options… > Outputs tab. Select any or all of the Slope Steepness, 

Slope Elevation Change, or Slope Horizontal Distance check boxes.

The Worksheet then includes a Map section with text boxes for data.
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The contour interval is the difference in elevation between adjacent topographic contours on a topographic 

map.

The map distance is the distance between two points on a map generally expressed in inches or centimeters.

Number of contour intervals is a count between two points on a map.

If only slope values are requested as output, then only Map input variables are requested. An existing Work-

sheet, SlopeMap.bpw, showing this configuration is found in the ExampleWorksheets folder.

14.2. Map distances

To specify that output calculated distances should also be given in map units use the Configure > Module 

selection command and select the Display output distances in map units check box below the list of 

modules.

When a distance is calculated in SURFACE, SIZE, or SPOT and the Display output distances in map 

units check box is selected, a Map Representative Fraction (1:x) text box is added to the Worksheet 

and map distances are added to the list of output variables.
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For example, when the Spread Distance check box is selected in the Configure > Module selection > 

SURFACE > Options… > Outputs tab the following Worksheet results:
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15. Units
Default units for BehavePlus are English for use in the United States It is 

easy to change all units to metric using the Configure > Units > Metric 

command.

If a user wishes to use something other than the units we have selected for English or metric, a custom set of 

units can be defined and saved for later use. 

The Units set also defines the number of decimal places displayed for each variable. 

Note that whenever a Worksheet or Run is saved, its current units of measure and display decimals are saved 

with it. The next time you open the Worksheet or Run, the units and decimal settings are restored.

BehavePlus also provides a quick units conversion tool accessed with the Tools > Units converter com-

mand.

15.1. English or metric

The units set can be changed using the Configure > Units > English or Metric or Custom commands. 

Immediately upon change, the units on the active Worksheet and all values that have been entered are changed.

Because units are stored with a Worksheet or Run, if units are changed to metric and then another Worksheet 

is loaded from the ExamplesWorksheets folder, with the File > New command, the new Worksheet will be 

English units.

15.2. Custom units set

Develop and save a custom units set using the “Units Editor” dialog box opened with the Tools > units Edi-

tor command.

The Units editor controls the selection of units of measure and decimal places for the input, display, and output 

of variables. The selected units are then applied to the current Worksheet and saved as a custom units set. 

The units of measure initially displayed by the dialog are those in use for the current Worksheet. 

Select the desired units for each variable set. Rather than repetitiously having to enter units for every variable, 

they are grouped by type of unit of measure.

Once you have defined and saved a custom units set, you can apply it to a Worksheet or Run with the Config-

ure > Units > Custom command that opens the “Select A Units Set” dialog box.

15.3. Number of decimal places

In addition to setting units of measure, the “Units Editor” dialog box also allows you to change the number of 

digits displayed after the decimal place of all input and output variables.
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For example, fire area has 1 decimal place as the default. You may want to round area to the nearest acre by 

changing the number of decimals to 0.

15.4. Units conversion tool

For all those times when somebody gives you an observed spread rate in furlongs/fortnight or you just need to 

know what the temperature is at that Canadian RAWS station just across the border, BehavePlus has a utility 

you can reach with the Tools > Units converter command.

In the “Units Conversion Tool” dialog box enter your known observation into the From Amount and From 

Units text boxes (12.3 meters per second in the above example). Then enter the desired units in the Into 

Units text box and click the Convert button to get your results (27.5143 miles per hour in the above exam-

ple).

In the “Help” pane of the “Units Conversion Tool” dialog box there is a list of all the available units.
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16. Language
The FIRE1 program of the old BEHAVE system was translated into several 

languages including Spanish and Chinese. We have designed BehavePlus to 

make the translation process easier. A Portuguese translation is included as an example. Instructions are avail-

able for translation to other languages. This translation process applies to the program interface itself, not to 

the help files. 

16.1. English or Portuguese

To change the language from the default English to Portuguese use the Configure > Language > Portu-

guese (Portugal) command.

16.2. Custom language set

To develop a custom language set contact Collin Bevins at cbevins@montana.com
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17. Fine Dead Fuel Moisture Tool
This tool is an automation of only the daytime tables from Rothermel 

(1983). Since these tables are not based on equations, they can't effectively 

be linked to any other tools or modules in BehavePlus.

The "Fine Dead Fuel Moisture Tool" dialog box can be accessed with the Tools > Fine dead fuel moisture 

command.

Inputs are made through the drop down lists. As soon as a change is made, the results are displayed.

17.1. Saving and Documenting

You can save fine dead fuel moisture inputs and results as a HTML file.

A Description text box at the bottom of the input section permits documentation of the saved results.

When the Export button is clicked, a “Save As HTML” dialog box appears. You may navigate to any drive or 

directory and select an existing file or specify a new file name. If you select an existing file, a popup will ask you 

to confirm overwriting the existing file. If you specify a new file without a “.html” or “.htm” extension, a “.html” 
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extension is automatically added. The contents of the “Fine Dead Fuel Moisture Tool” dialog box are then writ-

ten to the file in HTML format.

You may view the results using any web browser such as FireFox, Mozilla, or even Internet Explorer. You may 

also attach the file to E-mail, or post it to a web site.
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18. RH Tool
The “Relative Humidity” dialog box is opened with the Tools > Relative 

humidity command.

The “Relative Humidity” dialog box provides three ways to calculate relative humidity depending on available 

inputs, a column of text boxes for each method. 

• All three methods require Dry Bulb Temperature as an input.

• The first column utilizes a Wet Bulb Temperature input, the second the Wet Bulb Depression (the differ-

ence between Wet and Dry Bulb Temperatures), and the third way uses the Dew Point Temperature.

• The first and second methods also require the Elevation of the temperature observations.

Simply type or use the spin box to enter the wet and dry bulb temperatures and elevation. The dew point tem-

perature and relative humidity immediately change with input changes.

Remember the RH Tool is a stand alone utility, it does not link to any other tools or modules.



RH Tool BehavePlus v2.0 User’s Guide

100 USDA Forest Service General Technical Report RMRS-GTR-106WWW. 2003



USDA Forest Service General Technical Report RMRS-GTR-106WWW. 2005 101

19. Sun-Moon Calendar Tool
The "Sun-Moon Calendar" dialog box is opened with the Tools > Sun-

moon calendar command.

This tool allows you to specify any month of any year at a location on the globe and generate a calendar of sun-

rise, sun-set, civil dawn, civil dusk, moon-rise, and moon-set times in table or calendar format. It can also display 

a table of equinox, solstice, and moon phases for the year.

The calendar tool also includes a large database of named places within the United States so you can select a 

location by name rather than by coordinates.
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20. File management

20.1. Workspaces

BehavePlus has a proscribed file system structure; all files must be located in specific subdirectories. The parent 

directory of this file structure and all its subdirectories and files are collectively known as a Workspace.

A Workspace is a complete subdirectory tree containing all required BehavePlus files plus any additional Work-

sheet, Run, Fuel Model, Moisture Scenario, Units Set, or screen capture files saved by the user. A Workspace 

corresponds to a single BehavePlus project, and each BehavePlus project should have its own Workspace. 

Workspaces are created with either the File > Workspaces > New workspace or Clone current 

workspace commands.

When BehavePlus is first installed it has a single Workspace called the "DefaultDataFolder". This is the default 

current Workspace every time BehavePlus is started.

We recommend you create a new Workspace using the File > Workspaces > New Workspace command 

for every BehavePlus project you're working on. A project can be a collection of fire behavior projections for a 

wildfire or a fuels analysis for an environmental impact statement. The new, “pristine” Workspace is automati-

cally populated with all example Worksheets, example Runs, and standard and predefined custom fuel models 

just like the DefaultDataFolder Workspace.

Alternatively, you may clone an existing Workspace with the File > Workspaces >Clone current work-

space command to copy all of the current Workspace into a new Workspace, including all Run, Units Sets, 

custom Fuel Models, and custom Moisture Scenarios.

The Workspace concept provides the following benefits:

• All files pertaining to a specific training class, fire situation, or other project are segregated into their own 

file structure.

• Workspaces are easily backed up or copied onto removable media using either the File > Workspaces 

> Clone current workspace command or Windows Explorer.

• BehavePlus has self-validation tests and informs you whenever it is missing required files.

• BehavePlus knows where to find all custom Fuel Models and Moisture Scenarios and include them in 

Guide Button dialog boxes.
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We recommend using a compression utility such as WinZip, PKZip, or gzip when E-mailing or moving a Work-

space over the Internet as compression significantly reduces BehavePlus file sizes.

A list of three letter file extensions used by BehavePlus is shown in the following table. These extensions are 

automatically attached to the files you create in BehavePlus.

20.2. Load a Worksheet

A previously saved Worksheet is loaded with the File > New command, which opens the “Select a Work-

sheet” dialog box.

The Worksheet is 'blank' in that none of the input variables have been assigned values. But all of the associated 

options are still part of the Worksheet (e.g., graph appearance). 

20.3. Load a Run

A previously saved Run is loaded through File > Open Run command, which opens the “Select a Run” dialog 

box.

A Run is a Worksheet with valid values assigned to all input variables. Calculated values, tables, graphs, and dia-

grams are not saved. These are generated with the File > Calculate command.

20.4. Save as…

A sub-menu of the File > saveAs command offers many choices of what to save from the active Worksheet 

or Run:

• Run

• Worksheet

• Fuel models

• Moisture scenario

• Results

• Image

A Run can be saved only if all valid values have been assigned to all variables on the Worksheet. The Run can be 

opened at a later time using the File > Open Run command or the  toolbar button.

File extension File type Folder

.bpf Custom fuel models FuelModelFolder

.bpm Moisture scenarios MoistureScenarioFolder

.bpw Worksheets WorksheetFolder

.bpr Runs RunFolder

.bpu Custom Units Sets UnitsSetFolder

.exe Executable program file BehavePlus

.png Portable network graphic image format MyScreenCaptures

.bmp Bitmap graphic image format MyScreenCaptures

.jpg JPEG graphic image format MyScreenCaptures

.xml Extensible Markup Language Various places
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When a Worksheet is saved, it is saved without any values assigned to input variables. The Worksheet can be 

opened at a later time using the File > New command or the  toolbar button. 

Fuel models can be saved in either BehavePlus or the FARSITE Custom Fuel Model (.fmd) format. Before saving 

a fuel model make sure the SURFACE module check box is selected and the fuel parameters check box is 

selected in the Fuel is entered as section of the SURFACE > Options… > Fuel & Moisture tab. Valid 

values must be assigned to each fuel model parameter. Also make sure the Fuel Model Type parameter is 

correct, dynamic (D) fuel models must have a live herbaceous fuel load. (see Section 12.4) To use custom fuel 

models at a later time they must be attached with the Configure > Fuel model set selection command. 

(see Section 12.5.2)

Before saving a moisture scenario make sure the SURFACE module is selected and the individual size class 

check box is selected in the Moisture is entered by section of the SURFACE > Options… > Fuel & 

Moisture tab. Valid values must be assigned to each size class, even those that are shaded. To make a moisture 

scenario available use the Configure > moisture Scenario set selection command. (See Section 13.2)

Table results can be saved to a tab delimited text file or HTML file. The text file can then be imported into 

another application, such as word processor, spreadsheet, or database. The HTML file can be used in a Web 

page or is a handy, compact way to E-mail your BehavePlus results. (See Sections 10.5.2 and 10.5.3)

Images of table, graph, and diagram screens can all be saved as an image file. The image file can then be edited 

with an image processor or inserted into word processor or layout documents. (See Section 10.5.1)

The following example saves a Worksheet. The process is similar for other file types. The File > saveAs com-

mand requests input of folder name, file name, file description, or file type in the “Save As” dialog box.

In this case, the Worksheet Folder text box is initially set to MyWorksheets. To create a new folder, simply 

type a new name into the Worksheet Folder text box: TestFolder in the above example. You are asked to 

enter a Worksheet folder description. The folder description subsequently appears in the file selection dialog 

box as a reminder of its contents. The Worksheet description is initially set to whatever is in the Description 

text box on the Worksheet. When saving a Worksheet, you should assure that it describes the blank Work-

sheet, not the specific Run.

To export your table output as a spreadsheet or HTML document use the Export > Results command. 

20.5. Deleting Files & Folders

Files and folders in a BehavePlus Workspace are deleted using Windows Explorer. However you should only 

delete files and folders you create, not any of the files and folders BehavePlus creates for the Workspace.



File management DRAFT BehavePlus v3.0 User’s Guide

106 USDA Forest Service General Technical Report RMRS-GTR-106WWW. 2005



USDA Forest Service General Technical Report RMRS-GTR-106WWW. 2005 107

21. Help
Help features are a primary feature of BehavePlus. The Users Guide is avail-

able from the menu bar, and all dialogs and wizards include a help browser 

pane. Input fields include a Guide  button for help in entering range inputs or selecting one or more discrete 

choices. 

21.1. Browser pane help

The right-hand pane of many BehavePlus dialog boxes is a help browser. These can be printed by right-clicking in 

the help window to display a shortcut menu and selecting the appropriate command.

It includes a description of input variables when the guide button associated with the variable on the Worksheet 

is clicked. It includes a description of output variables when the cursor is held over a variable name on the list 

of possible output variables for a MODULE, reached through Configure > Module selection > MODULE 

> Options… > Outputs tab.

For each variable, information includes

• Short description

• Input to modules

• Output from modules

• More Information

• See also

• Links

21.2. Guide button

Help on entering a specific Worksheet variable is available by pressing the Guide  button next to each Work-

sheet entry field to activate an "Input Guide" dialog box containing a help browser pane and input assistance. 
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For continuous variables, the dialog facilitates entry of a large number of inputs by specifying the minimum input 

value, maximum input value, and increment value.

Additional values are sometimes displayed by clicking the Choices button where available in the "Input Guide" 

dialog box.

For discrete variables the dialog contains a list of all valid inputs from which the user may select values.

21.3. User's Guide

This User's Guide can either be printed or accessed interactively using a PDF viewer such as Adobe Acrobat 

Reader. It serves as the online help for BehavePlus and can be opened with the Help > Program help com-

mand. When viewed with the Adobe Acrobat Reader, the contents at the left provide access to the section in 

question.
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Appendix A: Version Comparison
This appendix contains a summary of changes between BEHAVE and the versions of BehavePlus. The different 

versions were introduced on the following dates.

Older versions of the software are available in the ARCHIVES section at www.fire.org.

Version 2 and Version 3

• Van Wagner’s (1977) transition to crown fire and Rothermel’s (1991) crown fire spread models have been 

added with the new CROWN module.

• Calculating wind adjustment factors is now a SURFACE module option.

• The expanded set of fuel models (Scott and Burgan, in prep) have been added.

• Support for dynamic fuel models has been added.

• Two new output variables have been added to the SURFACE module to help understand dynamic fuel 

modeling, Live herb load transfer and Dead herb fuel load.

• Moisture Scenarios used in developing the expanded fuel models have been added.

• Identifying acceptable ranges of fire behavior with table shading is included to replace RxWINDOW from 

the old BEHAVE system.

• Output tables can be exported into Microsoft Excel and HTML format files.

• The new example Worksheet, BasicStart.bpw, is loaded at startup so the user can quickly do a simple run 

without having to load a Worksheet or configure one.

• A new example Worksheet, SurfaceCrown.bpw is included.

• Several new example Runs are available, FuelCompare.bpr, FuelMoisWInd.bpr, and FuelWind.bpr, 

• Module names are listed with the output variables and run options shown on the Worksheet.

• A new option for listing descriptions of discrete variable codes on the Worksheet are added.

• The Fuel/Vegetation input category has been split into two new categories; Fuel/Vegetation, Sur-

face/Understory and Fuel/Vegetation, Overstory.

• A new input category named Acceptable Fire Conditions is displayed on a Worksheet when the 

Table shading for acceptable fire conditions option is selected.

• P-G has been added to the input variables used specifically for the palmetto-gallberry fuel model.

• The RH Tool has been removed as a module and is now included in the Tool menu. This was done since 

the RH module did not link to any of the other modules.

• The Probability of Ignition module now draws a smooth curve on the output graphs instead of the steps 

in previous versions.

Version Date

BEHAVE 1984

BehavePlus v1.0.0 January, 2002

BehavePlus v2.0.0 July, 2003

BehavePlus v3.0.0 January, 2005
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Version 1 and Version 2

• Following are significant differences between BehavePlus version 1.0 and version 2.0. Minor changes are 

not listed here.

• Safety zone size model added as a new SAFETY module

• Containment model added as a new CONTAIN module. This is a new model that allows multiple 

resources to make direct or parallel attack.

• Probability of ignition by lightning model added to the IGNITE module

• Two fuel weighting, three methods added to the SURFACE module 

• Dynamic palmetto-gallberry fuel model added to the SURFACE module

• Size diagram output added to SIZE

• Contain diagram output in CONTAIN

• Direction diagram added to SURFACE

• Fire characteristics chart diagram output added to SURFACE

• Fine dead fuel moisture added as a new tool

• A Run Option section is added to the worksheets for clarification

• The contents of the Notes section on example worksheets is blank. The description of the worksheet 

that was there for version 1 is not necessary, especially with the addition of the Run Options section. 

• The 'Standard' worksheet folder that was supplied with version 1 of the program is called the Example-

Worksheets folder in version 2 to better reflect what it is. The worksheets in that folder are just some that 

the developers put together. The term 'standard' gave them significance that they didn't deserve. 

• The Blank.bpw Worksheet that was in version 1 is called the 0Startup.bpw Worksheet in version 2 to 

better reflect what it is-the worksheet to use as a startup in selecting calculation modules. The '0' (zero) as 

a first character of the file name puts it as the first item on the list for easy selection.

• The program now automatically loads the 0Startup.bpw worksheet upon initiation. This saves some steps 

if the worksheet is set up by module selection. If a previously saved worksheet is desired, it is selected and 

loaded as before with the File > New command.

• The Fuel model guide button gives you access to the photographs and descriptions in Anderson (1982) 

"Aids to selecting fuel models" and to the selection key in Rothermel (1983) "How to predict the spread 

and intensity of forest and range fires" 

• The Program Help and the Users Guide for version 1 have been replaced by a single, new document-a 

users guide in PDF format that can be both printed and accessed online for specific help.

• A Language option has been added. Portuguese is provided as an example.

• Additional Workspace options aid in file management.

• Graph Y-axis are now user-scalable.

BEHAVE and BehavePlus

The old BEHAVE fire behavior prediction and fuel modeling system is a set of five DOS programs, three of 

which were first available in 1984. The whole look and feel of the BehavePlus fire modeling system is different, 

using modern user interface technology

Following are some specific differences that will be of interest to users of the old BEHAVE system.

• BehavePlus is one program. The old BEHAVE was five programs (FIRE1, FIRE2, RXWINDOW, NEWMDL, 

TSTMDL). The separation was due to computer limitations at the time and an extended development 

period.

• BehavePlus gives the user control of input options that were fixed on the old BEHAVE. For example, in 

the old BEHAVE, the DIRECT module required direct input of fuel moisture by size class, midflame wind 

speed, and direction of wind and spread with respect to upslope. The SITE module calculated fine fuel 

moisture and requested input of 20-ft. wind speed, exposure to the wind, and direction of wind and spread. 
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The DISPATCH module requested dead and live fuel moisture, 20-ft. wind speed and wind adjustment fac-

tor. Calculations were for upslope spread with the wind. In the TSTMDL program, fuel moisture was spec-

ified by category. In contrast, the BehavePlus SURFACE module allows users to specify the method of entry 

for fuel moisture, wind speed, and directions. 

• In BEHAVE only continuous variables could be assigned more than one value for a maximum of seven val-

ues. For example, wind speed could be assigned a range of values, but fuel model could not. BehavePlus 

allows multiple input values for every variable and there is essentially no limit to the number of values. 

Table output is carried over to multiple pages if necessary.

• BehavePlus produces graphs and diagrams as well as tables. The primary output of the old BEHAVE was 

tables. Crude graphs were produced using characters.

• The fuel modeling portion of the old BEHAVE consisted of the NEWMDL and TSTMDL programs. The 

features in NEWMDL are not in BehavePlus. The TSTMDL fuel model testing methods are in BehavePlus.

• BehavePlus does not include the fine dead fuel moisture model in MOISTURE and SITE modules in the 

FIRE2 program of BEHAVE. A better moisture model based on hourly weather data has been developed 

and is being incorporated into the National Fire Danger Rating System (NFDRS) and the FireFamily Plus 

program. Eventually it will be available for fire behavior calculations in BehavePlus. BehavePlus offers the fuel 

moisture tables as a tool.

• The CONTAIN module of BehavePlus is different from that used in BEHAVE. The old model had a math-

ematical problem that occasionally surfaced. BehavePlus uses a model by Fried and Fried (1996) that offers 

the application of multiple resources with various productivity rates and arrival times, and direct or parallel 

attack at either the fire head or rear. BehavePlus does not offer the option of reverse calculation that was 

in the old BEHAVE (i.e. given a final fire size, what is the required line production rate).

• The RxWindow program is not and will not be part of BehavePlus. Reverse calculation becomes more dif-

ficult (essentially impossible) as models are added. The plan is to provide a new method of table shading to 

aid in prescribed fire planning.

• The equations in the MORTALITY module in BehavePlus have been updated to match those of FOFEM. 

Many new tree species have been added.

• BehavePlus lists input values by category (Fuel/Vegetation, Weather, …) rather than by module (DIRECT, 

SIZE, …) as was done in the old BEHAVE.

• In BehavePlus users select the output variables to be displayed. In BEHAVE the output list was fixed.

• Map distance calculation was a stand-alone feature in BEHAVE. It is integrated into BehavePlus.

• BEHAVE asked users whether they were using a computer with a screen. The program could be run in 

either WORDY or TERSE mode. BehavePlus assumes it is being run on a 21st century personal computer.



Version Comparison BehavePlus v3.0 User’s Guide

114 USDA Forest Service General Technical Report RMRS-GTR-106WWW. 2005



USDA Forest Service General Technical Report RMRS-GTR-106WWW. 2005 115

Appendix B: Input and Output Variable Tables
Each input variable in BehavePlus, version 3.0, is listed in the following Table 1 according to category. 'I' (for 

Input) in a Module column indicates that it is a possible input for that module. In some cases an input variable 

may also be an output variable, indicated by 'O' (for Output). It depends on the selected modules, input 

options, and output variables. 

For example, note that 

• Midflame wind speed is an input to SURFACE under the input option Wind speed is entered as mid-

flame height. However, it is an output variable if Wind speed is entered as 20-ft. wind and wind 

adjustment factor is selected.

• Rate is spread is an output from SURFACE and an input to SIZE. If both SURFACE and SIZE are selected, 

the rate of spread from SURFACE is automatically used in SIZE. If only SIZE is selected, then the user must 

input values for rate of spread.

• Temperature is used only in SCORCH and RH, it is not used for the spread rate and intensity calculations 

in SURFACE.

• These tables also give the English and metric units and number of decimal places and the output variables 

selected for display initiated by the 0Startup.bpw worksheet. (See Appendix D.)
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Table 1: Input Variables and Modules

Input variable
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Range/

Units

Metric 

Range/

Units

Notes

Fuel / Vegetation, 

Surface/Understory

Fuel model I D N/A N/A

First fuel model I D N/A N/A For two fuel models

Second fuel model I D N/A N/A "

First fuel model cover-

age
I C 0-100% 0-100% "

Fuel model type I D S or D S or D Static or Dynamic

1-h fuel load I C 0.0-30.49 ton/ac 0.0-68.35 tonne/ha Fuel model parameter

10-h fuel load I C 0.0-30.49 ton/ac 0.0-68.35 tonne/ha "

100-h fuel load I C 0.0-30.49 ton/ac 0.0-68.35 tonne/ha "

Live herbaceous fuel 

load
I C 0.0-30.49 ton/ac 0.0-68.35 tonne/ha "

Live woody fuel load I C 0.0-30.49 ton/ac 0.0-68.35 tonne/ha "

1-h surface area / vol 

ratio
I C 109-4,000 ft2/ft3 358-13,123 m2/m3 "

Live herb surface area / 

vol ratio
I C 109-4,000 ft2/ft3 358-13,123 m2/m3 "

Live woody surface area 

/ vol ratio
I C 109-4,000 ft2/ft3 358-13,123 m2/m3 "

Fuel bed depth I/O C 0.05 to 10.0 ft 0.02-3.05 m "output for P-G

Dead fuel moisture of 

extinction
I C 5 - 100% 5 - 100% Fuel model parameter

Dead fuel heat content I C
6,000-12,000 BTU/

lb
13,967-27,934kJ/kg "

Live fuel heat content I C
6,000-12,000 BTU/

lb
13,967-27,934kJ/kg "

P-G age of rough I C 1-25 years 1-25 years

For palmetto-gall-

berry surface fuel 

option
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P-G height of under-

story
I C 1-6 ft 0 -2 m "

P-G palmetto coverage I C 15-85 % 15-85 % "

P-G overstory basal 

area
I C 30-110 ft2/ac 6.8-25.3 m2/ha "

Lightning ignition fuel 

type
I D

PPL, PWC, PWD, 

PWS, LPD, DFD, 

ESH, PMC

PPL, PWC, PWD, 

PWS, LPD, DFD, 

ESH, PMC

Lightning duff and litter 

depth
I C 0-12 in 0-30 cm

Fuel / Vegetation, 

Overstory

Canopy cover I C 0-100% 0-100%

Canopy height I I C 0-300 ft 0-91 m

Tree height I I C 10-300 ft 3-91 m

Crown ratio I I C 0.1 - 1.0 0.1 - 1.0

Canopy base height I C 0.1-100 ft 0-30.5 m

Canopy bulk density I C 0.001-0.062 lb/ft3 0.010-1.001 kg/m3

Mortality tree species I I D (206 species) (206 species)

Spot tree species I D (14 species) (14 species)

D.B.H. I I C 5 - 40 in 13 - 102 cm

Bark thickness I/O C 0.1 - 2.0 in 0.3 - 5.1 cm

Fuel Moisture

Moisture scenario I I D N/A N/A

1-h moisture I I I C 1 - 60% 1 - 60%
Fuel moisture scenario 

parameter

10-h moisture I I C 1 - 60% 1 - 60% "

100-h moisture I I C 1 - 60% 1 - 60% "

Live herbaceous mois-

ture
I C 30 - 300% 30 - 300%

"

Live foliage for 

P-G
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Live woody moisture I I C 30 - 300% 30 - 300%

"

Live stemwood 

for P-G

Dead fuel moisture I C 1 - 60% 1 - 60%
Used for 1-h, 10-h, 

100-h

Live fuel moisture I C 30 - 300% 30 - 300%
Used for live herba-

ceous and woody

Foliar moisture I C 30 - 300% 30 - 300%
Overstory conifer nee-

dles

Weather

Midflame wind speed I/O I C 0 - 60 mi/h 0.0 - 96.6 km/h

20-ft (or 10-m) wind 

speed
I I I C 0 - 99 mi/h 0.0 - 159 km/h

Wind adjustment factor I/O C 0.1 - 1.0 0.1 - 1.0

Effective wind speed O I C 0 - 60 mi/h 0.0 - 96.6 km/h

Wind direction (from 

North) or (from ups-

lope)

I C 0 - 360 deg 0 - 360 deg
Reference depends on 

input option selections

Air temperature I I I C -40 - 120 deg F -40 - 49 deg C

Fuel shading from the 

sun
I C 0 - 100% 0 - 100% by cloud or canopy

Lightning strike type I D +,  -, or unknown +, -, or unknown

Terrain

Slope steepness I C
0 - 45 deg 0 - 

100%

0 - 45 deg 0 - 

100%

Aspect I C 0 - 360 deg 0 - 360 deg

Ridge-to-valley eleva-

tion difference
I C 0 - 4,000 ft 0 - 1,219 m

Ridge-to-valley horizon-

tal distance
I C 0 - 4.0 mi 0 - 6.4 km

Spotting source location I D RT, MW, VB, ML RT, MW, VB, ML
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Fire

Rate of spread (maxi-

mum)
O I I C 0 - 500 ch/h 0.0-167.6 m/min Head fire

Flame length O I I I I C 0 - 200 ft 0 - 61 m

Worst-case estimate of 

flame height for 

SAFETY. Can be used 

to calculate FLI for 

CROWN

Fireline intensity O I I C 0 - 10,000 BTU/ft/s 0 - 34,641 kW/m

Flame height from a 

burning pile
I C 0 - 100 ft 0 - 30.5 m

Spread direction (from 

North) or (from ups-

lope)

I/O C 0 - 360 deg 0 - 360 deg
Reference depends on 

input option selections

Number of torching 

trees
I C 0 - 30 0 - 30

Scorch height O I C 0 - 200 ft 0 - 61 m

Elapsed time I I I C 0.5 - 8.0 h 0.5 - 8.0 h
From ignition/start for 

SIZE link to CONTAIN

Fire size at report O I C 0.1-100 ac 0.0-40.5 ha 'area' from SIZE

Length-to-width ratio O I C 1-7 1-7

Map

Map representative frac-

tion (1:x)
I I I C 1,980 - 1,013,760 1,980 - 1,013,760

Contour interval I C 1  - 1000 ft 0.3 - 304.8 m

Map distance I C 0.1 - 100 in 0.3 - 254 cm

Number of contour 

intervals
I C 1 - 100 1 - 100

Suppression

Suppression tactic I D Head or Rear Head or Rear

Line construction offset I C 0-100 ch 0-2012 m
0 = direct attack, 

else parallel attack

Table 1: Input Variables and Modules
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I = Input

O = Output

I/O = Input or Output depending on the selected modules and options

C = Continuous variable

D = Discrete variable

Resource name I D N/A N/A

If multiple resources, 

entry for each 

resource

Resource line produc-

tion rate
I C 1-200 ch/h 20.1-4023.4 m/h "

Resource arrival time I C 0-8 h 0-8 h "

Resource duration I C 0.0-10 h 0.0-10 h "

Resource base cost I C 0-500,000 0-500,000 "

Resource hourly cost I C 0-500,000 0-500,000 "

Number of personnel I C 1-200 1-200 Integer

Area per person I C 10-100 ft2 .93-9.3 m2

Number of heavy equip-

ment
I C 0-10 0-10 Integer

Area per  heavy equip-

ment
I C 100-500 ft2 9.3-46.5 m2

Table 1: Input Variables and Modules
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Table 2: Output Variables and Modules

Output variable

Default 

output 

variable

Table 

shading 

variable

Available 

as a map 

distance

English 

Units

Metric 

Units
Notes

SURFACE

Surface rate of spread X X ch/h m/min

Heat per unit area X X BTU/ft2 KJ/m2

Fireline intensity X X BTU/ft/s KW/m

Flame length X X ft m

Reaction intensity BTU/ft2/min KW/m2

Direction of maximum spread X degrees degrees

Surface spread distance X ch m

Midflame wind speed mi/h km/h

Wind adjustment factor fraction fraction

Effective wind speed mi/h km/h

Effective wind speed limit mi/h km/h

Maximum wind exceeded? X Yes or No Yes or No

Fuel load transfer percent percent

Dead herbaceous fuel load ton/ac tonne/ha

Slope steepness percent percent

Slope elevation change ft m

Slope horizontal distance ft m

Wind/slope/fire direction diagram N/A N/A

Fire characteristics chart N/A N/A

P-G dead fine fuel load ton/ac tonne/ha

P-G dead medium fuel load ton/ac tonne/ha

P-G dead foliage fuel load ton/ac tonne/ha

P-G live fine fuel load ton/ac tonne/ha

P-G live medium fuel load ton/ac tonne/ha

P-G live foliage fuel load ton/ac tonne/ha

P-G litter fuel load ton/ac tonne/ha

Fuel bed depth ft m
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CROWN

Critical surface intensity X Btu/ft/sec kW/m

Critical surface flame length ft m

Transition ratio X ratio ratio

Transition to crown fire X X Yes / No Yes / No

Crown ROS X X ch/h m/min

Critical crown ROS X ch/h m/min

Active ratio X ratio ratio

Active crown X X Yes / No Yes / No

Fire type X X

Surface

Torching

Crowning

Surface

Torching

Crowning

Crown spread distance X ch m

SAFETY

Safety zone separation distance X X ft m

Safety zone size X X ac ha

Safety zone radius X ft m

SIZE

Area X X ac ha

Perimeter X ch m

Length-to-width ratio N/A N/A Real number

Forward spread distance X ch m Can be map distance

Backing spread distance X ch m Can be map distance

Fire length X ch m Can be map distance

Maximum fire width X ch m Can be map distance

Fire shape diagram N/A N/A

CONTAIN

Time from report X X h h
To containment or 

escape

Table 2: Output Variables and Modules

Output variable

Default 

output 

variable

Table 

shading 

variable

Available 

as a map 

distance

English 

Units

Metric 

Units
Notes
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Contain status X X

Contained, 

Withdrawn, or 

Exhausted

Contained, 

Withdrawn, or 

Exhausted

Contained area X X ac ha

At containment.

If escape or withdrawn; 

area = 0

Fireline constructed X ch m

Number of resources used Integer Integer

Cost of resources used N/A N/A

Containment diagram N/A N/A

SPOT

Spotting distance from torching 

trees
X X X mi km

Spotting distance from a burning 

pile
X X mi km

Spotting distance from a wind-

driven surface fire
X X mi km

SCORCH

Scorch height X X ft m

MORTALITY

Bark thickness in cm

Tree crown length scorched ft m

Tree crown volume scorched X percent percent

Probability of mortality X X percent percent

IGNITE

Probability of ignition from a fire-

brand
X X percent percent

Probability of ignition from light-

ning
percent percent

Table 2: Output Variables and Modules

Output variable

Default 

output 

variable

Table 

shading 

variable

Available 

as a map 

distance

English 

Units

Metric 

Units
Notes
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Appendix C: The 0Startup.bpw worksheet, defaults
The 0Startup.bpw example Worksheet is provided as a “clean slate” starting place for selection of calculation 

modules. The 0Startup.bpw worksheet doesn't look like much on the screen, but it carries with it all of the 

'default' selections for calculation modules and displays. Any of those selections can be changed, of course. The 

0Startup.bpw worksheet can be reloaded at any time to reset the defaults. The 0 (zero) is the first character in 

the file name to assure that it is listed first in the list of Example Worksheets for easy selection.

If you want to use a different set of 'defaults', simply develop and save a similar startup worksheet in your own 

folder. For example, if you generally use metric units or if you prefer to display graphs as full screen rather than 

50%, then you can create your own “clean” worksheet. You will need to load it using the File > New com-

mand.

Following are the 'default' selections that come with the 0Startup.bpw worksheet.
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.

Table 1: Input Options

Module Input option 0startup.bpw selection Other options

SURFACE Fuel is entered as fuel models.

• fuel parameters.

• palmetto-gallberry.

• two fuel models, two-dimen-

sional expected spread.

• two fuel models, harmonic 

mean.

• two fuel models, area 

weighted.

Moisture is entered by individual size class.
• dead and live category.

• moisture scenario.

Wind speed is entered as midflame height.

• 20-ft wind and Input wind 

adjustment factor.

• 20-ft wind and Calculated wind 

adjustment factor.

• 10-m wind and Input wind 

adjustment factor.

• 10-m wind and Calculated 

wind adjustment factor.

Wind direction is specified on the worksheet. upslope.

Rate of spread is calcu-

lated

only in the direction of 

maximum spread.

in directions specified on the work-

sheet.

Wind & spread directions 

are

degrees clockwise from 

upslope (direction the wind 

is pushing the fire).

degrees clockwise from north (direc-

tion from which the wind is blowing).

Slope is specified as percent. degrees.

Slope steepness is specified on the worksheet. calculated from map measurements.

CROWN
Surface fire intensity is 

entered as
flame length. fireline intensity.

CONTAIN
Suppression input 

entered for
a single resource. multiple resources.

SCORCH
Fire intensity is entered 

as
flame length. fireline intensity.

MORTALITY Bark thickness is specified on the worksheet. estimated from species and d.b.h.
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Table 2: Outputs

Module
0Startup.bpw output variable 

selection

Other output variables

SURFACE

• Surface rate of spread 

• Heat per unit area 

• Fireline intensity 

• Flame length 

• Direction of maximum spread

• Maximum wind exceeded?

• Reaction Intensity 

• Surface Spread Distance

• Midflame Wind Speed

• Wind Adjustment Factor 

• Effective Wind Speed 

• Effective Wind Speed Limit

• Fuel Load Transfer

• Dead Herbaceous Fuel Load

• Slope Steepness

• Slope Elevation Change 

• Slope Horizontal Distance 

• Wind/Slope/Spread Direction Dia-

gram 

• Fire Characteristics Chart 

For palmetto-gallberry fuel option:

• P-G Dead Fine Fuel Load 

• P-G Dead Medium Fuel Load 

• P-G Dead Foliage Fuel Load 

• P-G Live Fine Fuel Load 

• P-G Live Medium Fuel Load 

• P-G Live Foliage Fuel Load 

• P-G Litter Fuel Load 

• Fuel Bed Depth

CROWN

• Critical Surface Intensity

• Transition Ratio

• Transition to Crown Fire ?

• Crown ROS

• Critical Crown ROS

• Active Ratio

• Active Crown ?

• Fire Type

• Critical Surface Flame Length

• Crown Spread Distance

SAFETY
• Safety Zone Separation Distance

• Safety Zone Size

• Safety Zone Radius

SIZE

• Area 

• Perimeter

• Length-to-Width Ratio 

• Forward Spread Distance 

• Backing Spread Distance 

• Fire Length 

• Maximum Fire Width 

• Fire Shape Diagram
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CONTAIN

• Time from Report 

• Contain Status 

• Contained Area 

• Fireline Constructed 

• Number of Resources Used

• Cost of Resources Used 

• Containmen Diagram

SPOT

• Spotting Distance from Torching 

Trees

• Spotting Distance from a Burning 

Pile 

• Spotting Distance from a Wind 

Driven Surface Fire

SCORCH • Scorch Height

MORTALITY

• Probability of Mortality • Bark Thickness 

• Tree Crown Length Scorched 

• Tree Crown Volume Scorched

IGNITE
• Probability of Ignition from a Fire-

brand

• Probability of Ignition from Light-

ning

Table 3: Menu Items

Menu item 0Startup.bpw selection Other options

View 100%
50, 67, 75, 83, 117, 133, 150, 167, 

200%

Configure > Module selection

None

SURFACE, SAFETY, SIZE,CON-

TAIN, SPOT, SCORCH, MORTAL-

ITY, IGNITE, RH

Display output distances in map 

units check box cleared

Display output distances in map 

units check box selected

Table shading for acceptable fire 

conditions check box cleared.

Table shading for acceptable fire 

conditions check box selected

Configure > Units English

Metric

Custom

Configure > Language English (US) Portuguese (Portugal)

Configure > Fuel model set selec-

tion
None

No other options.

Fuel model set selection must be 

done every time a Worksheet or 

Run is loaded

Configure > Moisture scenario set 

selection
None

No other options.

Moisture scenario set selection 

must be done every time a Work-

sheet or Run is loaded

Table 2: Outputs

Module
0Startup.bpw output variable 

selection

Other output variables
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Table 4: Appearance

Configure > 

Appearance Tab
Option

0Startup.bpw 

selection
Other options

Application

Show help pane Selected Cleared

Show picture pane Selected Cleared

Border Color Black Other colors

Border Width 1
0 = no border 

2-9= thicker border

Graph size

Graph Size (%) 50% 25-100%

Graph Title Short Long

X Axis Origin Zero Min value

Y Axis Origin Zero Min value

Graph elements

Background White Other colors

Rainbow Colors 3 4-18

Bar Color Red Other colors

Curve Points 20 4-100

Curve Color Rainbow colors Single color

Curve Width 3 0-9

Axis Color Black Other colors

Axis Width 1 2-9

Gridline Color Yellow Other colors

Gridline Width 1
0=no gridlines 

2-9=thicker gridlines

Page tabs

Display the page tab Cleared Selected

Tabs per Page 4
0 = no tabs 

1-10

Tab Position 1
0=no tabs 

1- #tabs per page

Tab Text Blank User defined

Tab Text Color Black Other color

Tab Font Size 12 8-24

Tables
Shade alternate table rows Selected Cleared

Shade Light Grey Other colors
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Worksheet

Fire projection documentation Cleared Selected

Training documentation Cleared Selected

Show input codes for all discrete 

variables
Cleared Selected

Show descriptions only for entered 

discrete variable codes
Selected

Show output variables to be calcu-

lated
Selected Cleared

Show notes section Selected Cleared

Notes lines 4 1-10

Table 4: Appearance

Configure > 

Appearance Tab
Option

0Startup.bpw 

selection
Other options
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Appendix D: Example Worksheets
BehavePlus allows the user to define and save a worksheet for later use. A set of Example Worksheets is pro-

vided with the program. Those worksheets are described in this appendix. A worksheet is selected through 

File > New. Clicking on the  by the Example Worksheets folder displays the following list. A double click on 

the Worksheet or selecting and clicking the Ok button loads the Worksheet.

It is important to recognize that these are only examples. We expect that users will set up their own folder of 

commonly used worksheets.

0Startup.bpw

This worksheet is a special case. It is used as the starting place for selecting calculation modules. It shows no 

input or output variables, but it sets defaults for all run settings as described in Appendix D. The 0Startup.bpw 

worksheet was used to initialize all of the following example worksheets.

BasicStart.bpw

This is the Worksheet that appears when you start BehavePlus. It is designed so the user can quickly do a simple 

run without having to load a Worksheet or configure one.

• Calculations are for maximum spread rate, upslope spread with the wind.

• Fuel moisture is entered by individual size class.

FuelModeling.bpw

This is the SURFACE module set up to examine the effect of changing fuel parameters, part of the process of 

developing a custom fuel model.

• Fuel is entered as fuel parameter.

• Fuel moisture is entered as moisture scenario.

• Wind is blowing upslope.

• Calculations are only for the direction of maximum spread.

• Only rate of spread (maximum) and flame length are selected as output.
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SlopeMap.bpw

This simple worksheet is used to calculate slope steepness from map measurements.  It is available from the 

SURFACE module.

• Slope steepness is specified to be calculated from map measurements.

• Only the slope output variables are selected.

SurfaceBasic.bpw

This worksheet is similar to the DIRECT module in the old BEHAVE. This method of specifying directions is 

used to show the relative effects of wind and slope by vectoring. Reference is to upslope, so there is no need to 

define aspect or reference directions with respect to north.

• A fuel moisture value is required for each size class.

• Calculations are only for the direction of maximum spread

• Wind and spread directions are specified as degrees clockwise from upslope

• Wind direction is specified as the direction the wind is pushing the fire

SurfaceBasicFrom.bpw

This worksheet is like SurfaceBasic.bpw except the other option for specifying directions is selected. This 

method of specifying directions is suited for onsite calculations for a specific location on the landscape. The 

wind direction is that used in weather forecasts.

• A fuel moisture value is required for each size class.

• Calculations are only for the direction of maximum spread.

• Wind and spread directions are specified as degrees clockwise from north.

• Wind direction is the direction from which the wind is blowing.

SurfaceCrown.bpw

This Worksheet links the SURFACE and CROWN modules. 

• A fuel moisture value is required for each size class.

• Canopy Base Height, Canopy Bulk Density, and Foliar Moisture are the inputs required for the CROWN 

module.

• Wind is blowing upslope.

• Wind is entered as 20-ft wind speed and wind adjustment factor (rather than as midflame wind speed).

• Calculations are only for the direction of maximum spread.

SurfaceMap.bpw

This worksheet might be used when using maps in projecting fire growth.

• The header includes those for 'fire projection documentation'.

• Output distances are displayed as map units.

• Calculations are only for the direction of maximum spread.

• Wind and spread directions are degrees clockwise from north.

• Wind direction is the direction from which the wind is blowing.

• Direction of maximum spread and spread distance are selected as additional output variables.

• Slope steepness is calculated from map measurements.
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SurfaceScorchMortality.bpw

This worksheet enables the three modules SURFACE, SCORCH, and MORTALITY.

• Calculations are for specified spread directions (rather than for the direction of maximum spread).

• Wind and spread directions are degrees clockwise from upslope.

• Wind direction is the direction the wind is pushing the fire.

SurfaceSimple.bpw

This worksheet is the ultimate simplification of the setup for a surface fire spread and intensity calculation. It 

can be used to examine relationships among the basic variables (fuel, moisture, wind, and slope) on surface fire 

spread. For specific fire behavior prediction, more information would be used.

• Fuel moisture is entered as dead and live category. A single value is used for 1-h, 10-h, and 100-h moisture 

content and another for live herbaceous and live woody fuel moisture.

• Calculations are for maximum spread rate, upslope spread with the wind.

SurfaceSpotIgnite.bpw

This worksheet enables the three modules; SURFACE, SPOT, and IGNITE

• Spotting distance is calculated from a wind-driven surface fire, which is the only spotting distance output 

option that makes sense for a link to SURFACE.

• Wind is entered as 20-ft wind speed and wind adjustment factor (rather than as midflame wind speed).

• Wind direction is upslope.

• Calculations are only for the direction of maximum spread (the only option that is valid for this spotting 

option).
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Index
Numerics

1 hr fuel moisture 97
123 73

A

acceptable fire conditions 38
Worksheet section 19

attaching

custom fuel models 81
moisture scenarios 85

axis origins 47
axis scales 46

B

BasicStart.bpw 15
bmp 73
borders

Worksheet 20
bpf 83
browser, using a 74
Button

Choices 28, 89
Convert 94
Export 97
first page 71
Guide 15, 27
Initialize from a Fuel Model 80
last page 71
next page 71
Options 23
previous page 71

C

Calculate Results dialog box 31, 32, 43, 44, 45,
46, 49
capture 73
cascade display 72
changing a Worksheet 22
check box

Contain Status 69
Display Graph Results 43
Display output distances in map units 91
Display table results 31
Fire Characteristics Chart 63
Fire projection documentation 17
Fire Shape Diagram 66
Shade alternate table rows 34
Show description for all discrete variable codes

18, 19
Show descriptions only for entered discrete

variable codes 18
Slope Elevation Change 90

Slope Horizontal Distance 90
Slope Steepness 90
Table shading for acceptable fire conditions 19,

37
Training documentation 17
Wind/Slope/Spread Direction Diagram 59

Choices button 28
civil dawn 101
civil dusk 101
clone Workspace 103
colors

graph 55
Contain Status check box 69
containment shape diagram 69
continiuous variable

entering 27
continuous variable 13
contour interval 91
Convert button 94
create

custom fuel models 79
moisture scenario 87
Workspace 103

curve points 57
custom fuel models 79

attaching 81
creating 79
FARSITE format 83
saving 79
set selection 81

D

dead herbacous fuel load 78
decimal places 93
DefaultDataFolder 103
define

custom fuel models 79
moisture scenario 87

delete

files and folders 105
dew point temperature 99
diagram 59

containment shape 69
fire characteristics chart 63
fire shape 66
image 73
Wind/slope/spread direction 59

dialog box

Appearance Options 20
Calculate Results - see Calculate Results dialog

box

Error 75



Index BehavePlus v3.0 User’s Guide

136 USDA Forest Service General Technical Report RMRS-GTR-106WWW. 2005

Fine Dead Fuel Moisture Tool 97
Fuel Model 81
Fuel Model Export Selection 84
Graph Limits 50
Input Guide 13, 27
Module Selection 23, 37
Moisture Scenario 85, 86
Mortality Module Options 23
Relative Humidity Tool 99
Save as 105
Select a Run 104
Select A Units Set 93
Select a Worksheet 21, 79, 104
Sun-Moon Calendar 101
Surface Module Options 90
Units Conversion Tool 94
Units Editor 93, 94

Directions tab 59
discrete variable 13

codes 18
entering 28

Display Graph Results check box 43
Display output distances in map units check box 91
Display table results check box 31
documentation section 16
dynamic fuel models 78

E

entering input variables 27
error checking 75
example Worksheet

0Startup.bpw 22
BasicStart.bpw 15
FuelModeling.bpw 79
SlopeMap.bpw 91
SurfaceBasicFrom.bpw 16

Excel 73
expanded fuel models 78
export

custom fuel models 83
fine dead fuel moisture 97
HTML file 74, 97
spreadsheet 73
table output 73
text file 73

Export button 97

F

FARSITE 1, 83, 84
file

Custom Fuel Model 83
HTML 74
image 73
spreadsheet 73

tab delimited text 73
file extensions 12, 104

123 73
bmp 73
bpf 83
fmd 83
html 74
jpg 73
png 73

file management 103
file structure 12, 103
Fine Dead Fuel Moisture Tool dialog box 97
fire characteristics chart 63
Fire Characteristics Chart check box 63
Fire projection documentation check box 17
fire shape diagram 66
Fire Shape Diagram check box 66
first page toolbar button 71
FlamMap 1, 83, 84
fmd 83
folder

description 105
new 105

folders

delete 105
Fuel Model

dialog box 81
Input Guide 78, 81

Fuel Model Export Selection dialog box 84
fuel models 77

attaching custom sets 81
create custom 79
custom 79
definition 13
dynamic 78
expanded set 78
FARSITE format 83
palmetto-gallberry 77
parameters 79
Save as 105
save custom 79
set selection 81
standard 13 77
type 78

fuel parameters 79
FuelModeling.bpw 79

G

Graph Elements tab 51
Graph Size tab 51
graphs 43

appearence 51
axis scales 46
colors 55
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curve points 57
image 73
limits 50
line widths 56
title 53
two variable 44
X-axis 46
Y-axis 48

Guide button 15, 27
definition 13

H

HTML file 74, 97

I

image 73
Initialize from a Fuel Model button 80
input codes 18
Input Guide dialog box 13, 27

Fuel Model 78, 81
Map Representative Fraction 89
Moisture Scenario 86

input section 17
input variables

entering 27
linked 29
multiple values 27, 28
ranges 27

installation

Windows 12
invalid input 75

J

jpg 73

L

language 95
last page toolbar button 71
line widths

graphs 56
Linked input variables 29
live herb load transfer 78
live herbacous moisture 78
loading

custom fuel models 81
fuel models 77
moisture scenarios 85
Run 104
Worksheet 21, 104

M

map

applications 89
distances 91
representative fraction 89, 91

scale 89
Map Representative Fraction dialog box 89
Model

definition 13
Module Selection dialog box 23, 37
Modules 23

definition 13
input options 23
linking 23
output options 24

moisture scenario 85
attaching sets 85
define 87
save 88
Save as 105
using 85
viewing 86

moon-rise 101
moon-set 101
Mortality Module Options dialog box 23

N

new

folder 105
Workspace 103

next page toolbar button 71
NEXUS 1, 83
notes section 20
number of curve points 57

O

Operation 7
Options button 23
output variables

tab 59, 63
output variables section 19
outputs

diagram - see diagram

graphs - see graphs

image 73
map distances 91
table shading 37
tables 31, 32, 39
two way tables 32
variables 24, 38

P

page buttons 71
page header section 16
page tabs 20
palmetto-gallberry 77
png 73
Portuguese version 95
prescription window 37
previous page toolbar button 71
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print 72

R

range of acceptable fire conditions 38
Relative Humidity Tool dialog box 99
Run

definition 13
delete 105
load 104
Save as 104

run option notes section 19
RXWINDOW 37

S

Save as 104
custom fuel model 80, 105
dialog box 105
HTML file 74, 97
image 73
images 105
moisture scenario 88, 105
results 105
Run 22, 104
spreadsheet 73
tab delimited file 73
Worksheet 22, 105

screen capture 73
sections - see Worksheet sections

Select a Run dialog box 104
Select A Units Set dialog box 93
Select a Worksheet dialog box 104
set selection

fuel models 77
moisture scenarios 85
units 93

Shade alternate table rows check box 34
Show description for all discrete variable codes

check box 18, 19
Show descriptions only for entered discrete variable

codes check box 18
size, window 71
slope

from map measurements 89
Slope Elevation Change check box 90
Slope Horizontal Distance check box 90
Slope Steepness check box 90
SlopeMap.bpw 91
spreadsheet 73
standard fuel models 77
Startup Worksheet 22
steepness

from map measurements 89
sub-models

list 7, 10

Sun-Moon Calander Tool 101
sun-rise 101
sun-set 101
SurfaceBasicFrom.bpw 16
system requirements 12

T

tab delimited text file 73
table shading

for acceptable fire conditions 37
for readability 34

Table shading for acceptable fire conditions check

box 19, 37
Tables

appearance 34
multiple pages 34
output 31, 32
row shading 34
saving 73, 105

tabs

Directions 59
Gragh Size - see Graph Size tab

Graph Elements 51
Graph Size 51
Output variables 59, 63
Outputs 90
page 20

tiled display 72
time

civil dawn 101
civil dusk 101
moon-rise 101
moon-set 101
sun-rise 101
sun-set 101

title

graphs 53
toolbar button 14

first page 71
last page 71
next page 71
previous page 71

tools

Fine Dead Fuel Moisture 97
Relative Humidity 99
Sun-Moon Calendar 101
Units conversion 94

Training documentation check box 17
two variable graph 44
two way tables 32

U

units 93
custom set 93
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decimal places 93
English 93
metric 93

Units Conversion Tool dialog box 94
Units Editor dialog box 93, 94

V

variables

input-see input variables

output-see output variables

view size 71
viewing

fuel model parameters 81
moisture scenario 86

W

web browser 74
wet bulb depression 99
wet bulb temperature 99
Wind/Slope/Spread Direction Diagram check box

59
Window 71

cascade 72
size 71
tiled 72

Windows installation 12
Worksheet 15–22

borders 20
definition 13
delete 105
editing 22

example - see example Worksheets

extension 12
layout 15
load 21, 104
Map section 90
Save as 105
saving 22
size 71
startup 22

Worksheet sections 16
acceptable fire conditions 19
documentation 16
input 17
notes 20
output variables 19
page header 16
run option notes 19

Workspace 103
clone 103
definition 13
new 103

X

X-axis 46
X-axis origin 47

Y

Y-axis 48
Y-axis origin 47
your 74
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Command Index
C

Configure

Appearance

Application 9
Application tab 20
Graph Elements tab 43, 51, 55
Graph Elements tab > Curve Points 57
Graph Elements tab > Line width 56
Graph Size tab 47, 51
Graph Size tab > Graph Title 53
Page Tabs tab 15, 20
Tables tab 34
Worksheet tab 15, 17, 18, 19, 20

Fuel model set selection 81, 82, 105
Language 11

English 95
Portuguese (Portugal) 95

Module 23
Module selection 14

CONTAIN > Options … > Output Variables

tab 69
Display output distances in map units check box

91
MORTALITY > Options… 23
Options… > Input Options tab 11
Options… > Output Variables tab 11, 24
Options… > Outputs tab 59
SIZE > Options … > Output Variables tab 66
SURFACE > Options… > Directions tab 59
SURFACE > Options… > Fuel & Moisture tab

77, 85, 87
SURFACE > Options… > Outputs tab 63, 78,

90, 92
SURFACE > Options… > Slope tab 89

moisture Scenario set selection 85, 105
Table shading for acceptable fire conditions

check box 15
Units

Custom 93
English 93
Metric 93

F

File

Calculate 14, 31, 104
New 14, 15, 21, 93, 104
Open Run 14, 104
Print 14, 72
saveAs 104

Fuel model > BehavePlus format 80
Fuel model > FARSITE format 84
Image 73
Moisture scenario 88
Results > HTML 74
Results > Spreadsheet 73
Run 22
Worksheet 22

Workspaces

Clone current workspace 13, 103
New workspace 13, 103

H

Help

Program help 9, 11, 14, 108

P

Pages menu 8, 14, 71

T

Tools

Fine dead fuel moisture 97
Relative humidity 99
Sun-moon calendar 101
Units converter 93, 94
units Editor 93

V

View > 71
View parameters 81

W

Windows

Cascade 72
TIle 72
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  The Rocky Mountain Research Station develops scientific information 
and technology to improve management, protection, and use of the 
forests and rangelands. Research is designed to meet the needs of 
National Forest managers, Federal and State agencies, public and 
private organizations, academic institutions, industry, and individuals. 

Studies accelerate solutions to problems involving ecosystems, 
range, forests, water, recreation, fire, resource inventory, land 
reclamation, community sustainability, forest engineering technology, 
multiple use economics, wildlife and fish habitat, and forest insects 
and diseases. Studies are conducted cooperatively, and applications 
may be found worldwide.

Research Locations

Flagstaff, Arizona Reno, Nevada
Fort Collins, Colorado* Albuquerque, New Mexico
Boise, Idaho Rapid City, South Dakota
Moscow, Idaho Logan, Utah
Bozeman, Montana Ogden, Utah
Missoula, Montana Provo, Utah
Lincoln, Nebraska Laramie, Wyoming

*Station Headquarters, Natural Resources Research Center,
2150 Centre Avenue, Building A, Fort Collins, CO 80526

The U.S. Department of Agriculture (USDA) prohibits discrimination 
in all its programs and activities on the basis of race, color, national 
origin, sex, religion, age, disability, political beliefs, sexual orientation, 
or marital or family status. (Not all prohibited bases apply to all 
programs.) Persons with disabilities who require alternative means for 
communication of program information (Braille, large print, audiotape, 
etc.) should contact USDA’s TARGET Center at (202) 720-2600 (voice 
and TDD).

To file a complaint of discrimination, write USDA, Director, Office of 
Civil Rights, Room 326-W, Whitten Building, 1400 Independence 
Avenue, SW, Washington, DC 20250-9410 or call (202) 720-5964 
(voice or TDD). USDA is an equal opportunity provider and employer.
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